I am using Ubuntu 18.04.1 version and now wants to use Windows 10 as well. I have downloaded WoeUSB to create bootable USB for Windows, but I'm getting the below error message when installing. Before this step I have formatted the USB as NTFS.

Installation failed!
Exit code: 256
Mounting source filesystem...
mount: /media/woeusb_source_1533820829_2541: wrong fs type, bad option, bad superblock on /dev/loop8, missing codepage or helper program, or other error.
mount_source_filesystem: Error: Unable to mount source media
Error: Unable to mount source filesystem
Unmounting and removing "/media/woeusb_source_1533820829_2541"...
umount: /media/woeusb_source_1533820829_2541: not mounted.
cleanup_mountpoint: Warning: Unable to unmount "/media/woeusb_source_1533820829_2541".
Some mountpoints are not unmount/cleaned successfully and must be done manually
You may now safely detach the target device
| improve this question | | | | |
  • 4
    Do you have a Windows installer ISO for Win10? That'll be a required step before you can even create a Windows 10 bootable disk. Also, consider using mkusb/dus instead (with their PPA: launchpad.net/~mkusb/+archive/ubuntu/ppa) rather than WoeUSB, because I know that mkusb/dus works out of the box rather than having to use some 'other' software that we can't verify works or even runs properly. – Thomas Ward Aug 9 '18 at 13:37
  • Hi Thomas,thanks for the reply. Yes, i have downloaded ISO file from Microsoft site. – niranjan sathe Aug 9 '18 at 13:47

Rather than using WOEUSB, try using a piece of software that I can confirm to work, called MKUSB (also known as "Do USB Stuff" / dus). (Ubuntu Wiki pages: MKUSB, MKUSB GUI)

There may be versions of this in the repositories already, but I prefer to have the 'latest' so I keep using the PPA, which is why I indicate to set up the PPA on your system specifically here.

First, install the MKUSB PPA so we get the latest MKUSB version:

sudo add-apt-repository ppa:mkusb/ppa
sudo apt-get update
sudo apt-get install mkusb mkusb-common dus guidus

Next, run mkusb. It'll ask you if you want to run the version called 'dus', we want to hit Yes at that screen.

enter image description here

It will open a terminal window for the console output, which is very useful to have so you can see the progress of the write tasks.

enter image description here

It should prompt you for your sudo credentials as well, however I'm running this from a Live USB at the moment so it doesn't prompt me, it just goes to the next screen in the GUI:

enter image description here

Once you click OK you'll see this screen. Choose "Install (make a boot device)" and hit OK: enter image description here

Then choose "Extracting Windows installer"

enter image description here

It will then open a page asking you to navigate to the ISO. Go to the ISO file, select it, then hit OK.

It'll then ask you to select the device you want to write to. This will overwrite all data on the selected device, so make sure you select the right one (in my system, /dev/sdc is the USB stick I'm going to put the Windows installer disk onto)

enter image description here

Click "OK" and it'll confirm you want to begin the write process.

It'll list the tasks it wants to do, and ask you if you really want to do this. Select "Go", then hit "Go" when you're ready for it to run.

The console window will gain focus and you can watch the 'progress':

enter image description here

This will take many of your system resources and will result in some slowness on your computer at times, so you might want to go get a coffee or read the newspaper or take a quick walk. This will take some time to complete, because it clones the ISO to a tarball, and then extracts the tarball to the target device.

When it's done, the GUI will return with this screen if it successfully created the disk:

enter image description here

Hit OK, and remove the disk from your computer. You can then shut down and boot to the installer USB stick that was created.

A warning: Once you install Windows, you will then need to boot to a LiveUSB for Ubuntu, and follow the steps to run Boot Repair (the link is from the Ubuntu Wiki) in order to restore Grub so you can boot into Linux again. Otherwise, you will only be able to boot into Windows (this is why Windows is typically installed first before you install Ubuntu).

| improve this answer | | | | |
  • Hey Thomas, thanks for detailed reply.how ever i am getting below error in mkusb. The target device is unmounted and you can unplug it. The system might not see the current partition table of the target device unless you re-plug it – niranjan sathe Aug 9 '18 at 14:32
  • @niranjansathe, I think it is a warning rather than an error message. Please unplug and re-plug the target device and continue. Will it work after that? – sudodus Aug 9 '18 at 14:40
  • @sudodus, done that but still it is appearing the same. – niranjan sathe Aug 9 '18 at 14:49
  • 1
    @niranjansathe That's not an error that's an indicator it's completed. Please if you can include the actual error message you're seeing. That "error" is actually just saying we're done, and you can unplug the USB stick. If you have any other messages, though, than "Done" or it gave you a condition that it exited with an error, please share that (either as a screenshot or as text via a PasteBin such as paste.ubuntu.com) and provide us the link to either the screenshot image or the pastebin of the text. – Thomas Ward Aug 9 '18 at 14:55
  • 1
    @niranjansathe, Have you tried to boot from the 'target' device, the USB pendrive? – sudodus Aug 9 '18 at 15:00

The Windows 10 install image is going to need NTFS, not FAT32.

WoeUSB GUI freaks out because the image is larger than the supported ISO file format supposedly - but will work from the command line.

Assuming SDD is your USB stick, first format a partition on it for NTFS. This partition will be SDD1, but in the command line you put the device, not the partition like so:

woeusb --target-filesystem NTFS --device ./Win10_1809Oct_English_x64.iso /dev/sdd

That command line worked perfectly for me to create a Windows 10 bootable stick from the Windows image download from Microsoft's site.

| improve this answer | | | | |

Format the USB drive as FAT32 (or whatever it may be called by your formatting program... just try all containing FAT) and simply copy all the files from the ISO to it.

UEFI BIOS'es can boot from FAT32 partitions - they will try to find a file efi\boot\bootx64.efi or efi\boot\bootia32.efi (not case sensitive) which you will notice is present on your typical Windows or Linux installation ISO image.

It is as simple as that nowadays. No need to use a special program that overwrites the boot sector anymore.

| improve this answer | | | | |
  • 2
    Win 10 install USB sticks need to be NTFS, not FAT32. – Tony Maro Mar 27 '19 at 15:53
  • @TonyMaro i have an uefi partitioned stick with a fat32 partition with the win 10 install files on it and it boots just fine. afaik the bios/uefi system is not required to be able to boot from an ntfs so I would be surprised if that worked. Never tried though. I realize that some usb drives might not even allow partitioning and I don‘t know how things work with legacy boot methods at all... – masterxilo Mar 29 '19 at 14:36
  • if you purchase Windows 10 today it comes on an NTFS formatted USB stick. I'd think if that wouldn't work a large percentage of time that Microsoft wouldn't do it. In my experience the fat32 usb stick wouldn't work with my official downloaded Win 10 fall creator's update version install image. But as they say, YMMV. – Tony Maro Apr 22 '19 at 1:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.