1

I had recently bought a WACOM One tablet pen, and I couldn't get it to work on Ubuntu (with gnome). I had installed the driver using the command:

sudo apt-get install xserver-xorg-input-wacom

The moment I had done that I restarted the system. But after booting, no input devices were working. So I had to reboot again, and go into recovery mode to reinstall all the input drivers using the command:

sudo apt-get install --reinstall xserver-xorg-input-all

Later, I was able to get the keyboard and mouse working, but I still cannot get the tablet working.

Command:

lsmod | grep wacom

Output:

wacom                 106496  0
usbhid                 49152  1 wacom
hid                   118784  3 hid_generic,usbhid,wacom

Command:

xsetwacom --list devices

Output: (nothing got displayed).

Command:

xinput list

Output:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse                id=9    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Logitech USB Keyboard                     id=10   [slave  keyboard (3)]
    ↳ Logitech USB Keyboard                     id=11   [slave  keyboard (3)]
    ↳ Eee PC WMI hotkeys                        id=12   [slave  keyboard (3)]

Command:

lsb_release -a

Output:

LSB Version:    core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-    noarch:printing-9.20160110ubuntu0.2-amd64:printing-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.5 LTS
Release:    16.04
Codename:   xenial

I had also tried reinstalling and restarting using the command:

sudo apt-get install --reinstall xserver-xorg-input-wacom

and it still does not work. What I am supposed to do now?

1 Answer 1

3

I'm not sure what kernel version you are running, but most likely you need to update your input-wacom kernel driver ( https://github.com/linuxwacom/input-wacom/wiki/Installing-input-wacom-from-source ) not your Wacom X server driver.

2
  • 1
    That actually worked! Thanks! Looks like installing it from source did the trick!
    – Sreram
    Commented Aug 10, 2018 at 6:48
  • I was confused because most answers and forums said, it has to be plug and play. But in my case it was not...
    – Sreram
    Commented Aug 10, 2018 at 6:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .