I have an HP Pavilion dm3 laptop running Ubuntu 11.10. My touchpad works perfectly fine, but with one exception, the scrolling does not work. Does anybody out there know of any sure-fire fix that exists out there?

closed as off-topic by Pilot6, Zanna, David Foerster, Elder Geek, amc Feb 15 '17 at 17:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Zanna, David Foerster, Elder Geek
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you tried installing the "synaptiks" software from the install center? That's how I got my scroll portion of my touchpad to work on my Alienware. – Shogun Feb 22 '12 at 5:50
  • open a terminal, type xinput list, identify how the touchpad is detected and add this to your question. This should help is giving more relevant answers. – To Do Dec 14 '12 at 8:45

The following commands fixed it for me (temporarily until reboot):

sudo rmmod psmouse
sudo modprobe psmouse proto=imps

And to make it permanent

sudo gedit /etc/modprobe.d/options

Add this line:

options psmouse proto=imps

Source: http://puzzlescript.wordpress.com/2010/07/04/fix-scrolling-not-working-on-touchpad-in-ubuntu-10-04/

Note: This fix will make the touchpad be recognized as a mouse instead, which will remove some features specific to touchpads such as disable while typing.

Not the answer you're looking for? Browse other questions tagged or ask your own question.