My laptop's WiFi card doesn't seem to work:

04:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)

I have tried installing the appropriate drivers from Intel's official website.

I am running Ubuntu 18.04.1

rfkill returns:

ID TYPE      DEVICE      SOFT      HARD
0 bluetooth hci0   unblocked unblocked
1 wlan      phy0   unblocked   blocked

I have also turned off secure boot. My WiFi works perfectly fine in Windows 10, however, it does not work at all in Ubuntu. This is a fresh install of Ubuntu so I am not opposed to reinstalling though I have already tried that once. If it's at all related, I have acpi=off set as a boot flag, otherwise my laptop freezes up after a minute of use. My laptop is an HP Pavilion 15t.

Also, here is the output of details about my wireless card provided by the all-in-one script.

If there is anymore information I can provide, don't hesitate to ask.

Edit: I have tried using a USB WiFi dongle that works with a Raspberry Pi and it does not work. It even shows as unblocked in the rfkill but still does not work.

Edit 2: Here is the output of iwconfig

wlx000f6006f65a  IEEE 802.11  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
      Retry short  long limit:2   RTS thr:off   Fragment thr:off
      Power Management:off

wlo1      IEEE 802.11  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Power Management:off

lo        no wireless extensions.

eno1      no wireless extensions.

A quick note, 'wlx000f6006f65a' is my USB WiFi dongle and 'wlo1' is my Intel WiFi card

Edit 3: During the initial installation of Ubuntu, when prompted to select my WiFi network, Intel Corporation Wireless 7265 (rev 59) was listed as a choice.

Edit 4: I have tried enabling networking in Recovery Mode, however it hangs after I hit yes to confirm remounting filesystem

Had also issues with Wifi on two laptops after installing 18.04 Fix: Replace default network manager with alternative. Here is one link: https://help.ubuntu.com/community/WICD

  • Tried that but upon restarting I was not able to access my settings panel. In addition to that, my WiFi still did not work so I reverted the change back to the original. – Thomas B. Aug 9 at 23:48

Try unplugging your computer from the power outlet, shutting it down and letting it sit for a few minutes. Then start it up (keeping it unplugged) and see what happens.

  • 1
    It's a laptop. I've tried removing the battery for a few minutes while it's unplugged, but that didn't work. – Thomas B. Aug 10 at 2:23
up vote 0 down vote accepted

Ok, so I finally managed to fix the problem. For some background info, my laptop has integrated graphics as well as a GTX 1050 Ti. In an attempt to fix another issue, I installed the Nvidia proprietary drivers for my graphics card. As part of this process, I had to set a MOK password and enable MOK upon reboot. I also deleted acpi=off from my boot flags. I believe deleting that boot flag fixed my issue, but in the case that it was because I enabled MOK, I am providing you all of that information.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.