0

I cannot access my photos stored on my Samsung S7 using Ubuntu 18.04. I know this question has been asked before, and I tried all of the solutions offered (e.g, trying a different USB port, different USB cable, installing mtp libraries, changing the setting on my phone etc.), and nothing has worked. After I plug the phone into my computer via USB, the computer recognizes it as a Samsung. Then I navigate to the folder where I want to get my photos from, and the file manager just freezes. I can't even unmount the device. I have to do it via unplugging the USB cable.

I bought this computer specifically for blogging, and I need to be able to get my photos on. :(

  • Welcome to Ask Ubuntu. This may not be your issue, but is your phone unlocked? I can't access my older galaxy phone if the phone is locked.. – guiverc Aug 9 '18 at 1:34
  • By locked, do you mean rooted? Is so, yea I believe my phone is locked because I got it through Verizon. EDIT: Just did a quick Google search, and it says the Verizon S7 is unlocked. – user10192832 Aug 9 '18 at 1:38
  • no, just your password (unlock pin) entered. at least on mine, if the [galaxy] screen is locked the pc connection gets nowhere & just hangs.. when I unlock the phone it suddenly works. – guiverc Aug 9 '18 at 1:53
  • If you are up for a little command line fu you can install android-tools-adb. It lets you push and pull files from the phone. – Organic Marble Aug 9 '18 at 1:55
  • Yes, my phone is unlocked with regards to the password. I tried the solution here but that didn't work either. Although, I saw that it worked for someone else. I can try the suggestion by Organic Marble. It seems like this is a chronic issue though. I see this question has been asked a few different times, and each one has hundreds of views. :( EDIT: Actually, doing this from the command line would be a pain. I need to be able to see the photos in a file manager. – user10192832 Aug 9 '18 at 1:58
0

Installing the exfat-utils repository worked for me. It seems that Ubuntu/Unix has problems accessing the Fat32 formatted SD card and even the phone's memory. After installing the exfat-utils from here I could access the SD card, main memory, and images of my Galaxy S7 without problems.

Important! If you ever connected the phone to a Windows OS make sure to "safely remove" it before unplugging the USB and connecting to Ubuntu. Otherwise, Ubuntu will not be able to handle it.

Here are the terminal commands as given by the authors of the package (make sure you have all relevant packages installed as listed in the link):

git clone https://github.com/relan/exfat.git
cd exfat
autoreconf --install
./configure
make

Then install driver and utilities (from root):

make install

You can remove them using this command (from root):

make uninstall

Do not forget to press "Allow" on your phone's popup window after establishing the USB connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.