3

Any help would be appreciated. I've looked over similar threads and have tried restarts and installing lightdm, but haven't had any success. I'm trying to use a second monitor through my laptop's single HDMI port and it worked yesterday before updating to 18.04.1, but now it isn't being detected. This is for a Toshiba Satellite, I don't know the exact model it's a couple years old the sticker with that info has rubbed off.

I have tried it with a second monitor and a different cable as well.

The xrandr output is:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
eDP-1 connected primary 1366x768+0+0 (normal left inverted right x axis y       axis) 309mm x 174mm
1366x768      60.00*+
1360x768      59.80    59.96  
1280x720      60.00    59.99    59.86    59.74  
1024x768      60.04    60.00  
960x720       60.00  
928x696       60.05  
896x672       60.01  
1024x576      59.95    59.96    59.90    59.82  
960x600       59.93    60.00  
960x540       59.96    59.99    59.63    59.82  
800x600       60.00    60.32    56.25  
840x525       60.01    59.88  
864x486       59.92    59.57  
800x512       60.17  
700x525       59.98  
800x450       59.95    59.82  
640x512       60.02  
720x450       59.89  
700x450       59.96    59.88  
640x480       60.00    59.94  
720x405       59.51    58.99  
684x384       59.88    59.85  
680x384       59.80    59.96  
640x400       59.88    59.98  
576x432       60.06  
640x360       59.86    59.83    59.84    59.32  
512x384       60.00  
512x288       60.00    59.92  
480x270       59.63    59.82  
400x300       60.32    56.34  
432x243       59.92    59.57  
320x240       60.05  
360x202       59.51    59.13  
320x180       59.84    59.32  

and in the display settings there is only my laptop's screen...

  • Please advise the make and model of the laptop, by clicking on the grey edit link above and left, and adding that to the lead paragraph. Please provide the ('engineering') model number from the serial number plate; the 'marketing' model number, e.g. "Insipidon 999" from the top or front of a PC is generic, and there could be dozens of different configurations called that with different components. – K7AAY Aug 8 '18 at 20:50
  • Have you tried switching from X to Wayland or vice versa? Also, did you upgrade to Ubuntu 18.04.1 or something-else 18.04.1 (like Xubuntu 18.04.1 or something)? – Chai T. Rex Aug 8 '18 at 21:11
  • I haven't tried this, how would I go about that? I was already on 18.04, did updates this morning when software update prompted me to and rebooted before heading to work. So I only noticed when I got home – ben pearlstine Aug 8 '18 at 21:13
  • The easiest way to switch between X and Wayland is described here. If that doesn't work here's more info. – Chai T. Rex Aug 8 '18 at 21:19
  • Thanks, just tried to switch to Wayland using the cog at sign in, unfortunately that's still not working. – ben pearlstine Aug 8 '18 at 21:23
0

Since, I do not have reputation enough to add a comment, I will add my experience here. My second screen worked before updating some packages in ubuntu 18.04. After the update and restart the hdmi port was completely off.

I have been trying different solutions such us moving from nvidia driver to nouveau and way back or executing dpkg-reconfigure gdm3. The syntoms were not having second screen detected even nor HDMI signal. The output of xrandr(xrandr --listmonitors) only printed the built-in screen (0: eDP).

My configuration is the following:

  • Ubuntu 18.04.1 LTS
  • kernel: 4.15.0-38-generic (uname -a)
  • Xorg: 1:7.7+19ubuntu7.1 (apt-cache show xserver-xorg | grep Version)
  • gdm3: 3.28.3-0ubuntu18.04.3 (apt-cache show gdm3 | grep Version)

At the end, the steps that worked for me were the following:

  • move to intel driver: sudo prime-select intel
  • reboot
  • reconfigure gdm3: sudo dpkg-reconfigure gdm3
  • reboot
  • restart display-manager: sudo systemctl restart display-manager
  • reboot

Good luck, if you suffer this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.