3

I have installed Ubuntu 18.04 but found gnome too heavy for my old hardware.

So I installed Xubuntu-desktop:

sudo apt-get install xubuntu-desktop synaptic
sudo apt-get remove gdm3
sudo dpkg-reconfigure lightdm
sudo apt-get remove nautilus nautilus-* gnome-power-manager gnome-screensaver gnome-termina* gnome-pane* gnome-applet* gnome-bluetooth gnome-desktop* gnome-sessio* gnome-user* gnome-shell-common zeitgeist-core libzeitgeist* gnome-control-center gnome-screenshot && sudo apt-get autoremove

It worked beautifully, but now, sometimes xscreensaver locks my screen, sometimes lightlocker does.

I have them both installed, apparently:

$ sudo dpkg -l | grep locker
rc  gnome-screensaver                                           3.6.1-8ubuntu3                                     amd64        GNOME screen saver and locker
ii  light-locker                                                1.8.0-1ubuntu1                                     amd64        simple screen locker for lightDM display manager
ii  light-locker-settings                                       1.5.0-0ubuntu2                                     all          simple configuration tool for light-locker
$ sudo dpkg -l | grep xscreen
ii  xscreensaver                                                5.36-1ubuntu1                                      amd64        Screensaver daemon and frontend for X11
ii  xscreensaver-data                                           5.36-1ubuntu1                                      amd64        Screen saver modules for screensaver frontends
$ 

This is my production workstation and I'm afraid of messing it.

Having them working at the same time presents no huge problem for me, but it looks inconsistent.

I have a "Lightlocker settings" icon on my "Settings" app, but it doesn't work. So I can only configure sleep timeouts for xscreensaver. Would it be safe to remove xscreensaver (which is uglier)? And is there a way to make "Lightlicker settings" actually work and allow me to configure its timeouts? Or should I keep xscreensaver and remove lightlocker?

Thanks!

  • Well, here's what I figured out... In XFCE, once you suspend, that's the command that the system invokes: xfce4-session-logout -s – Thiago Garcia Sep 1 '18 at 18:54
2

I have also had problems with lightlocker/xscreensaver conflicts in the past with Lubuntu.

I prevented lightlocker from automatically starting by executing

sudo mv /etc/xdg/autostart/light-locker.desktop /etc/xdg/autostart/light-locker.desktop.bak

This is totally reversible should it cause problems.

I did this a while back when I was even newer to Ubuntu so there is probably a more elegant way.

  • 2
    I have uninstalled light-locker altogether and have no problems at all, whatsoever. – Thiago Garcia Aug 10 '18 at 11:42
1

Well, here's what I figured out...

In XFCE, once you suspend, that's the command that the system invokes:

xfce4-session-logout -s

In XFCE settings > "Session and Startup", the last tab "Advanced" has an option to "Lock screen before suspending". That is the same as the one you can find at the XFCE Power Manager > tab "System", option "Lock the screen when the computer is suspended".

Well, if the option above is checked, then xfce4-session-logout will invoke:

/usr/bin/xflock4

xflock4, in turn, doesn't lock anything, but tries to use any locker installed (such as xscreensaver, gnome-screensaver or light-locker).

I first tried installing gnome-screensaver, but its command (listed in xflock4) gave me errors on the command line:

gnome-screensaver-command -l

Then I tried installing light-locker, but its commands (listed in xflock4) also gave me errors on the command line:

light-locker-command -l

The errors for the 2 commands above were similar:

** Message: Received error message from the locker: GDBus.Error:org.freedesktop.DBus.Error.NotSupported: This method is not implemented

So I uninstalled them all (light-locker, light-locker-settings, and gnome-screensaver). Note: gnome-screensaver and light-locker were NOT installed at the same time.

Finally, I've installed xscreensaver:

sudo apt install xscreensaver

Its command to lock (listed in xflock4) works fine:

xscreensaver-command -l

So, XFCE's session and startup configuration, when it invokes xflock4, it eventually invokes the command above too, and my screen gets properly locked! It's working great and I only have to set it up properly by going to Settings >> Xscreensaver options / Power Manager options / Session and Startup options (changing the settings graphically).

I won't bother solving the issues of the other lockers (gnome-screensaver and light-locker).

Thank you for the help and tips, guys!

0

I just uninstalled xscreensaver on Xubuntu 18.04 and it didn't seem to cause any problems (now only light-locker runs when I lock the screen or have it wake from sleep; before, xscreensaver would lock my screen if I pressed ctrl+alt+l and both light-locker and xscreensaver would lock my screen upon waking up from sleep—so, I'd have to enter two passwords).

When I uninstalled xscreensaver, I didn't have to uninstall any other packages with it that depended on it.

You might try this to fix your settings:

sudo apt-get install light-locker-settings

It doesn't seem to be installed by default. I'm not sure why the icon is there for you unless you did install it (but mine works after installing it—I didn't see it there beforehand).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.