I had this same issue in my last attempt to upgrade (with a clean install) from 16.04 LTS to 18.04 LTS. When I am browsing internet and specially when I am playing videos my CPU+GPU raises to fast to high levels causing throttling to fire and producing intolerable lags, leaving the system unusable for about 60 seconds or more.

With Ubuntu 16.04 LTS I never experienced this problem. Of course temperatures raised and throttling fired frequently (after all this is a laptop), but system was never unusable and video playback was smooth.

My previous solution was to downgrade to 16.04 LTS again, but now I need the newer version so I want to find a solution.

System specs:

  • CPU: Intel Core i7-6500U
  • GPU: Intel HD Graphics 520
  • Ubuntu: 18.04 LTS
  • Linux: 4.15.0-30
  • Mesa: 18.0.5
  • Hardware acceleration: on


Definitively it is a problem with frequency throttling. Instead of throttling CPU frequency to avoid overheating the procesor, the system is waiting until temperature reaches a limit (default of 85ºC) and then intel_powerclamp module fires, turning the system unusable for 60 seconds or more.

I would expect a progressive performance degradation from intel_powerclamp, but no, it is all or nothing. ¿Can this be configured?

My current solution is a modification of the script of this answer. It seems to work, but it is a big hack. There must be a conventional way to tweak system configuration to accomplish the same result.


If I turn off frequency turbo boost (echo "1" | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo) the problem completely disappears. Temperature never reaches the limit and the script introduced on update 1 nor intel_powerclamp fires and the laptop is smooth and usable.

Problem now is that turbo boost is disabled. With Ubuntu 16.04 LTS I never had this issue.

This is clearly a bad configuration of the thermal management subsystem of Ubuntu 18.04 LTS. Is there a way to fix it?


System is still unusable. Installing Ubuntu 18.04 LTS server and anything else than Gnome3 works. Well, it's not a novelty that Gnome sucks, but it was usable with 16.04...

  • 2
    I experience the same issue with a i7-6500U when running CPU intensive tasks such as compressing/decompressing large files and especially compiling software with make. I tried limiting make to only use one process but that results in a longer runtime, more heat. In my case it does not throttle, but shuts the entire laptop down harshly.
    – Dave A
    Aug 7, 2018 at 23:55
  • Turbo boost is actually pretty useless in a 64 bit system. Unless you run some 32 bit applications often, there's no real disadvantage on keeping it disabled. Aug 14, 2018 at 9:24
  • Is there anything new to this?? I have similar problems. Ubuntu 18.04 or 20.04 overheat whereas 16.04 worked very fine, all this with default configuration. TLP doesn't solve this (even with configuring it powersave), nor the intel_pstate disabling. Lubuntu also overheats. Not a problem with the kernel version. No process taking all the power. So where is the problem???
    – user1098293
    Jun 23, 2020 at 17:18

5 Answers 5


Disable intel_pstate at boot by editing your grub configuration.

Open /etc/default/grub with your preferred text editor and locate the line that begins with:


And add intel_pstate=disable at the end of that string. Here's how mine looks after that:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_pstate=disable"

Now, execute:

sudo update-grub

And reboot your laptop. That's it. It should work as smooth and cool as with 16.04.

Some additional information: intel_pstate governor seems to be buggy, or just plain stupid and unable to detect quick temperature raises and reduce the processor speed in consequence. It seems it'd just pray to Saint Cooling Device for it to keep the CPU below the shutdown threshold. In a desktop computer with a DC9 turbine like fan such leap of faith maybe justified, but in laptops with one small fan like my XPS13 it's better to be skeptic and leave those things to the good old ACPI (Atheist Configuration and Power Interface). At least until the intel_pstate governor grow some brains.

And the turbo boost is mostly useless. Chances are that you won't lose anything for having it disabled. That feature was useful in the days of monocore 32 bit processor, but not in the 64 bit multicore world we're living on right now.

  • This solution didn't work on my laptop. Aug 12, 2018 at 15:20
  • It works pretty well in my XPS13, nonetheless it still enables turbo mode from time to time. You may try leaving intel_pstate enabled and disabling turbo mode altogether, since turbo mode doesn't actually improve real application working speed and it's the main cause of overheating. Just google "Ubuntu disable intel turbo boost", there are many answers on how to do so and add it to boot scripts. Good luck! Aug 14, 2018 at 9:18
  • 1
    BTW, there's also a Gnome Shell extension that may help you deal manually with the issue, or at least doing some testing to get a better understanding on where your problem lies on. It's called "CPU Power Manager". For both, disabling the turbo boost and using this extension, you need to have intel_pstate enabled, so if you changed your grub as suggested in my answer you'll have to reenable again by removing that intel_pstate=disable string from your GRUB_CMDLINE_LINUX_DEFAULT and executing sudo update-grub. Don't forget to reboot after that. Aug 14, 2018 at 9:21
  • Any source on that "turbo frequency is useless" claim? I find 37% raw frequency (3.7 GHz vs. 2.7 GHz) quite significant!
    – K3---rnc
    Jan 5, 2019 at 4:26
  • You missed a relevant "mostly" there. I think it depends on what you do. I did some benchmarking with multi-threaded apps with and without turbo in my i7 laptop and didn't notice any difference at all. Unfortunately I haven't found any comprehensive benchmarking comparing different intel processors with turbo enabled vs disabled, so I cannot say it's completely useless. Jan 18, 2019 at 20:06

I had issues with the i7-6500u as well.

Changes in the Linux kernel improved performance of Intel chips, with the side effect of causing thermal clamping on devices with a low thermal limit.

I found TLP helped a lot with toning down the behavior. Turning off turbo boost is another way to tame it. You can also set the fans to constantly run or come on at a lower temperature, which raises the thermal limit of the device.

  • Problem is still here; only less frequent. Aug 8, 2018 at 23:58
  • Everyone should install TLP even before heat problems start up. Keeps system cooler, keeps fans off or low speed more often and generally everything purring along nicely. Plus it does extra stuff for when on battery power. Besides deactivating turbo boost, consider lowering the maximum frequency from say 3,500 MHz to 3,000 Mhz or 2,500 MHz. It makes things slower of course but has less heat. Aug 9, 2018 at 0:15
  • @WinEunuuchs2Unix The thing is that I don't need any workaround on Ubuntu 16.04. Why Ubuntu 18.04 needs them? Who knows... Aug 10, 2018 at 21:45
  • @user3368561 You can try the same kernel version you were using under 16.04. Something like 4.4.0-131 or 4.13.0-36. Ubuntu 16.04.5 LTS uses the 18.04 kernel now 4.15.0-29 / -30 and I had to move off of it because it prevented Laptop from suspending. I went back to older 4.13.0-36 which works fine. Aug 10, 2018 at 23:07
  • @WinEunuuchs2Unix I'm using 4.15.0-30 without problems. They changed something else on 18.04 that screwed up a bunch of laptops (just look at bug reports, there are hundreds of users with similar issues). Aug 10, 2018 at 23:18


As mentioned on this thread tlp works wonders for keeping system under control. It works with thermald, Intel Powerclamp, Battery vs AC for USB power, etc. Although highly configurable I've never had to change the configuration settings for a pleasant Out-Of-The-Box experience. Prior to using it I had all kinds of problems with an IvyBridge laptop overheating all the time. I have it on my new Skylake laptop and the fans NEVER run except when doing Ubuntu 16.04 LTS to 18.04 upgrade.

You can get a very detailed write-up with installation instructions here: Stop cpu from overheating

As an aside I've read a few questions the last two weeks from people wanting to override the minimum frequency, maximum frequency or to fix the current frequency at a specific speed. As such I've decided to create a new bash+yad GUI project. A tab to display temperatures for all thermal zones and issuing notify-send (pop-up bubble messages) will be part of it. As well some sort of session log file for when you weren't watching the screen might be kept.

I just had the idea 2 hours ago whilst rereading this thread. No promises on doing the project but I think a few people would like it and I would have a lot of fun :)

  • thank you, but tlp just solved my CPU overheating for GPU installing the proper driver solved my problem Sep 12, 2020 at 21:33
  • TLP does little to nothing for overheating on my newish high end system.
    – Lexible
    Oct 4, 2020 at 17:12
  • @Lexible My skylake system never overheats. Very new systems sometimes have to wait awhile for tlp updates. Some say they are better without tlp and built in manufacturing cooling works fine as is. Just because it doesn't work for you isn't a reason to downvote this answer. You should complain to tlp developers instead. Oct 4, 2020 at 21:18
  • Been waiting over a year. Is that long enough?
    – Lexible
    Oct 5, 2020 at 16:24

Upgrade to kernel 5.3 fix my problem not more system shutdown due to high temperatures. I updated using:



Dell Inspiron 17-5770 with Intel i7-8550 and dual Gpu here, heat and bus problems with Ubuntu 18.04 installed. Every time there is a system driver update seems to push the hardware hotter and slower. Last update had the case at 140F and the CPU at 160F while watching YouTube lag at 140p in a 70F room with plenty of air flow. This is what worked for me:

sudo nano /etc/default/grub

Find the line that starts with GRUB_CMDLINE_LINUX_DEFAULT= and add these comments within the quotes.

pci=nomsi pci=noaer

I.E. after your edit it might say this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi pci=noaer"

Then update the grub with:

sudo update-grub

I don't believe this is a proper fix. But if your operating system is on the verge of destroying your computer, find what works and hope an update comes along that doesn't make things worse.

Best luck

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .