1

screenshot of Language Support

I have reinstalled my computer system with the Ubuntu 18.04 last night, and while I install the system I chose the system language is English but there is Chinese language package installed without my agreement now. (What happened exactly?)

I try to remove this language in the Install/Remove Languages... button, but when I open the language setting, the system warns me there is some recommended package not installed and want to install it for me. (I do not need it at all.)

So, is there any ways to remove this language showing in the screenshot?

P.s. I tried to upload the image many times and the upload page always says: Failed to upload image; imgur is rejecting the request. So, I have to use Google Photos to share this screenshot.

Here is the outputs of commands apt update && apt upgrade:

sudo apt update && sudo apt upgrade
Hit:1 http://packages.microsoft.com/repos/vscode stable InRelease
Hit:2 http://mirrors.tuna.tsinghua.edu.cn/ubuntu bionic InRelease              
Hit:3 http://mirrors.tuna.tsinghua.edu.cn/ubuntu bionic-updates InRelease      
Ign:4 http://dl.google.com/linux/chrome/deb stable InRelease                   
Hit:5 http://mirrors.tuna.tsinghua.edu.cn/ubuntu bionic-backports InRelease    
Hit:6 http://mirrors.tuna.tsinghua.edu.cn/ubuntu bionic-security InRelease     
Hit:7 http://dl.google.com/linux/chrome/deb stable Release                     
Hit:8 http://ppa.launchpad.net/daniruiz/flat-remix/ubuntu bionic InRelease
Hit:10 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu bionic InRelease 
Hit:11 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic InRelease   
Hit:12 http://ppa.launchpad.net/numix/ppa/ubuntu bionic InRelease              
Hit:13 http://ppa.launchpad.net/system76/pop/ubuntu bionic InRelease           
Reading package lists... Done 
Building dependency tree       
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

And the output of command ls /usr/share/locale-langpack is:

ls /usr/share/locale-langpack 
en  en_AU  en@boldquot  en_CA  en_GB  en@quot  en@shaw  en_US  zh  zh_CN
18
  • See this askubuntu.com/questions/515330/… – George Udosen Aug 7 '18 at 17:07
  • @GeorgeUdosen Fine.Thx~ – Hatsune Aug 7 '18 at 17:12
  • Just ignore the prompt to install language pack support, and go ahead and remove the Chinese language. (But first make sure that that language is not set as the "regional formats" setting.) – Gunnar Hjalmarsson Aug 7 '18 at 17:15
  • @GeorgeUdosen After I followed the prompts on the page, I still couldn’t delete the Chinese language pack that appeared on the page. – Hatsune Aug 7 '18 at 17:21
  • @GunnarHjalmarsson "Regional Formats" has been set as "English(United States)", I had been tried to remove this Chinese language but the "汉语(中国)" still appeared on the "Language Support" page now. – Hatsune Aug 7 '18 at 17:25
1

Thanks for Mr.Hjalmarsson's help.

Follow this Steps:

First, make sure that language which you want to make it disappear in this page is not set as the "regional formats" setting.

Then check the folder which in /usr/share/locale-langpack and using command ls like this:

ls /usr/share/locale-lanpack/zh
en  en_AU  en@boldquot  en_CA  en_GB  en@quot  en@shaw  en_US  zh  zh_CN

We can see there has a language folder which you want to remove like zh, this zh folder was created by the installer since you (apparently) selected a Chinese time zone location, so we removed it now.

sudo rmdir /usr/share/locale-langpack/zh

At last, we use the command gnome-language-selector to remove the Chinese language packages again and re-open the gnome-language-selector, the "汉语(中国)" will never appear.

If you can't see the "汉语(中国)", we should do some clean work after remove, so, just remove all of the folders which have the characters zh in the folders name.

2
  • It may be worth mentioning that the zh folder was created by the installer since you (apparently) selected a Chinese time zone location. Personally I consider it to be a bug in the installer, but I won't get further into the details in this comment. – Gunnar Hjalmarsson Aug 7 '18 at 19:51
  • @GunnarHjalmarsson Ok, I will add your suggestion in the answer. – Hatsune Aug 9 '18 at 14:51
0

Check your languages pack supports with:

sudo apt search language-pack

if you want remove the Chinese language, try

sudo apt-get remove language-pack-zh-hans language-pack-zh-hans-base language-pack-zh-hant language-pack-zh-hant-base

Hope this helps.

6
  • The first command return this: zsh: no matched found: language-pack*, and I delete the character "*", it works. – Hatsune Aug 7 '18 at 17:29
  • @Hatsune Can you please edit your question and let us know the output – abu-ahmed al-khatiri Aug 7 '18 at 17:30
  • And the second command I have tried but while I open the "Language Support" there still warn you to install the recommended package. And the "汉语(中国)" was not disappearing. – Hatsune Aug 7 '18 at 17:32
  • The whole output of "apt search"? – Hatsune Aug 7 '18 at 17:33
  • @Hatsune i think close your gnome-language-selector first, and try again with sudo apt-get remove check-language-support 1 zh. (zh is Chinese language code). – abu-ahmed al-khatiri Aug 7 '18 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.