5

I am facing an issue with apt : sudo apt-get update won't successfully complete on my Ubuntu 18.04 Desktop.

First I'd like to specify that the subject Xenial repository does not have a release file did not solve my problems, nor did Ubuntu repository does not have a release file or any other.

My distro is a fresh installed Ubuntu 18.04.1 Bionic.

The problem is, on a sudo apt-get update I get the following error messages :

E: The repository 'http://security.ubuntu.com/ubuntu bionic-security Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I get these messages on EACH REPOSITORY of my sources.list, the defaults ones for Ubuntu 18.04.

Here is the content my /etc/apt/sources.list file (I git it from Ubuntu Official Documentation). I removed the commented lines to improve readability.

 # deb cdrom:[Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426)]/ bionic main restricted
deb http://us.archive.ubuntu.com/ubuntu/ bionic main restricted
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
deb http://us.archive.ubuntu.com/ubuntu/ bionic universe
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates universe
deb http://us.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
deb http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse

I have understood by reading posts about that error msg, that it often comes from a bad configuration of repositories in that file (e.g, asking for the bionic version of a package which has not already been published on bionic repos).

The thing is: these are the default repositories. And when I go check the dist folder in the url given, I can see the distros specified in configuration : bionic, bionic-updates and bionic-security.

So, to sum it up:

  • I have only the official default repositories for Ubuntu Bionic 18.04 configured
  • each and every one of them get the same error (does not have Release file)
  • any hint I've found is about one specific repository, or about a full system upgrade, which is not my case

If someone have an idea, a hint or even better, a solution to make sudo apt-get update work, I'd be really grateful !

Thanks

closed as unclear what you're asking by waltinator, N0rbert, Kevin Bowen, Thomas, Volker Siegel Aug 8 '18 at 16:12

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • In your sources.list there's always a space after http://. If you have that in your actual file please remove it and try updating again. – Florian Diesch Aug 7 '18 at 15:55
  • @Florian OP had a note at the bottom saying the spaces were added on purpose. I just fixed the formatting. – wjandrea Aug 7 '18 at 16:27
  • Are you using a proxy or VPN? Are you on a home network or university/corporate network? Are you in the USA? – wjandrea Aug 7 '18 at 16:36
  • 1
    As a side note, Ubuntu repositories are not PPAs - the latter are a separate type of unofficial repository – Zanna Aug 7 '18 at 19:27
  • 1
    @wjandrea : I am behind a corporate proxy. I added the proxy configuration to /etc/apt/apt.conf, as follows : Acquire::http::Proxy "http://myUser:myPassword@companyProxy:proxyPortNumber". This configuration seems OK to me, since I can "sudo apt-get install" a package (e.g, ` sudo apt-get install peco` did install peco correctly). It sudo apt-get update command that raises the error. I am located in europe. I tried fr.archive.ubuntu mirror, as well as uk.archive.ubuntu mirror, with the same results. And I am not behind any VPN. – Zolano Aug 8 '18 at 6:57