11

Hello I recently installed Ubuntu 18.04 from Windows 10 and so far it's good, but I have a problem. Youtube is freezing every 30 seconds for like 1 or 2 seconds. I watched a movie and it didn't have a problem but it's freezing with Youtube.

If someone could help me I will be very happy to continue my experience with Ubuntu ! :)

5
  • Hi there. How did you install your Ubuntu: is it a virtual machine? Have you configured a dual boot? Have you erased your Windows and are only relying on Ubuntu now? Your installation type is important to understand where the problem comes from. – avazula Aug 7 '18 at 14:28
  • Wiped Windows 10. I really want to just use Ubuntu on my second machine aka for watching movies, netflix, youtube and etc. – Miroslav Aug 7 '18 at 14:31
  • Would this help? – avazula Aug 7 '18 at 14:34
  • No, i tried it 1 hour ago, and right now but still freezing. – Miroslav Aug 7 '18 at 14:42
  • @Predator1112 I updated Ubuntu and it fixed my issues. If you have problems with that goto the corresponding question. – Santropedro Apr 8 '19 at 3:19
0

From my experience it can be caused by the internet browser (chrome) but if you use firefox it's probably not that.

6
  • I'm using Chrome. I really can't switch to Firefox. Everything for me is based aroung Chrome and Google's ecosystem. My computer and my phone and my tablet is linked to chrome. – Miroslav Aug 7 '18 at 14:44
  • 2
    Can you test one minute to watch a youtube video on firefox ? it is freezing or not ? – Jerare Aug 7 '18 at 14:48
  • 1
    I watched 5 minute video without a problem. So it's a problem with Chrome on Linux. Thanks for the info about the Chrome. I will try to use it :) – Miroslav Aug 7 '18 at 14:53
  • @Predator1112 don't forget to mark the answer as accepted if you found it useful. – avazula Aug 7 '18 at 15:24
  • 1
    While this describes the issue in (slightly) more detail, this is not an answer to the issue. Nor is this a viable workaround for those of us who rely on chrome. – RTbecard Nov 16 '18 at 17:26
13

This happened to me too. It turns out to be a Chrome issue. Neither FF not Epiphany makes momentary sticky freezes nor halts while video playing. (decoding)

When you check chrome://gpu/ you will notice that Hardware Protected Video Decode part indicates that hardware acceleration is not available in Linux. Inorder to fix that go to chrome://flags/ and enable the Override software rendering list and restart Chrome. It worked for me.

4
  • This solved the problem for me on Elementary OS Juno (a derivative of Ubuntu 18.04). – RTbecard Nov 16 '18 at 17:28
  • 4
    This DIDN'T solve it for me. – Santropedro Feb 18 '19 at 17:03
  • Even worst, this made chrome to crash when more than around 10 tabs were open, and they were just innocent wikipedia tabs and one youtube video in low resolution. – Santropedro Mar 3 '19 at 23:53
  • Hi @Santropedro, how did you solve this? I know it has been a long time but if you remember anything, please share. – Anshuman Kumar Feb 11 at 4:46
0

I have disabled "Use hardware acceleration when available" in chrome settings and it solved the problem.

1
  • Worked for me even though the problem is happening across chrome, chromium, brave. (Not Firefox it seems). But the question is, what does it mean that running videos on my browser can't use GPU acceleration when they've been able to for years with Ubuntu 18.04? – iJames Nov 17 '20 at 20:06
0

I had the same issues, I tried all of these solutions like switching off hardware acceleration (however, Chrome began hanging quite a bit for me but that is due to the high number of tabs I have open) and also it did not really work. I tried the other solutions and none worked. I restarted my computer and it worked temporarily only. But try that also just in case, you never know it might just work.

In the end, I tried checking what extensions were having access to YouTube from Chrome, I tried switching them all off except for the bare essentials (which was AdBlock), so what happened was I had an extension called HabitLab which definitely has some bugs because once I switched it off, YouTube began working normally. So the best thing for you to do might be to check your Chrome Extensions one by one (if the other solutions are not for you)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.