11

I'm upgrading Ubuntu on a new laptop , 16.04 to 18.04, following instructions here.

The last command I ran was:

sudo do-release-upgrade -d

Now I'm stuck on

To continue please press [ENTER]

Inhibiting until Ctrl+C is pressed...

I can't say exactly, but I started upgrading about three hours ago. It seems to me that the upgrade is taking too long. I also noticed that I have no network activity in System Monitor, and the Total Received number is less than the upgrade download size (which is 1 189 M).

Is this possible to check my upgrade status? May the System Monitor received size not taking into account any traffic?

UPDATE

I canceled the process and I saw that there's actually an error.

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)

E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

So I looked for the process that was blocking it

sudo lsof /var/lib/dpkg/lock

It happened to be aptd. I checked its pid

ps -e | grep aptd

and killed it

sudo kill -9 14806

After that I was able to run (as @Jos suggested):

sudo apt install -f

And started the upgrade process from the beginning.

5
  • Your update process ought to give you a complete log of what is being downloaded, unpacked, installed and configured. If it doesn't, you can interrupt the upgrade and do sudo apt install -f to see where you were. – Jos Aug 7 '18 at 13:09
  • @Jos Sorry for asking twice :) Do I understand correctly that the log is supposed to display in the terminal ? Because I there's no download messages, at least not in the terminal. – sr9yar Aug 7 '18 at 13:19
  • Yes, straight after the do-release-upgrade. – Jos Aug 7 '18 at 13:20
  • See here as well: askubuntu.com/questions/146308/… – Jos Aug 7 '18 at 13:23
  • @Jos Thanks for the link, although I've read it already. :) I've managed to upgrade successfully. Your comment helped, so if you care to add it as an answer, I will accept it, for the completeness' sake. Thanks a lot. – sr9yar Aug 7 '18 at 14:37
1

Your update process ought to give you a complete log of what is being downloaded, unpacked, installed and configured. If it doesn't, there is something wrong, but at this point we can only speculate what. However, you can simply interrupt the upgrade with Ctrl + C. Then do sudo apt install -f to see where you were.

One thing may have gone wrong though. If the upgrade process was running, then early on your Ubuntu version string was changed (in your case from xenial to bionic) in /etc/apt/sources.list. You may need to change that back before retrying the upgrade.

47

I got the same message. Pressing Enter got it going. Not sure what the message means, but pressing Enter did the upgrade from there.

5
  • 1
    Same problem caused me all kinds of annoyances: askubuntu.com/questions/1031881/… – WinEunuuchs2Unix Aug 11 '18 at 20:47
  • 5
    Glad I found this answer! Was waiting for something to happen when upgrading to 18.10 and after pressing Enter the upgrade really started. – Leonti Oct 18 '18 at 22:56
  • 4
    Same here. I must have waited 20m for something to happen. To be clear, you need to hit enter twice. The first time you're prompted and hitting enter brings up the message "Inhibiting until Ctrl+C is pressed..." The second time is not prompted, but you still need to hit enter. Once you do you'll see the upgrade messages indicating package downloading, selecting, unpacking, etc. – mikemtnbikes Mar 3 '20 at 9:29
  • This is a problem from bionic to focal as well... weird interface – Ray Foss Apr 23 '20 at 19:50
  • Same to Groovy Gorilla. Very confusing message :( – Jan Wielemaker Nov 16 '20 at 16:31
4

I just had the same. How I fixed it:

  1. cp /etc/apt/source.list.distUpgrade
  2. apt update
  3. sudo do-release-upgrade

It then should start installing again. Do not press Ctrl+C, but just hit [ENTER]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.