0

I recently received a new work laptop (HP Elitebook) with Windows 10 installed. I want to install a Ubuntu distribution on a separate partition, and since it's my first time doing this on UEFI and along Win10 I was using this guide. And thought I succeeded...

When I turn on my computer, it boots into GRUB as desired, with options for Ubuntu and Windows boot loader. Windows side works fine. The Ubuntu side, however, left the screen blank for an extended time (over ten minutes) and on subsequent boots after a hard reset, it kernel panics before doing anything:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
CPU: 2 PID: 1 Comm: swapper/0 Not tainted 4.150-20-generic #21-Ubuntu
Hardware name: HP HP EliteBook Folio 1040 G3/80FA, BIOS M83 Ver. 01.21 1/30/2018
Call Trace:

snip

Both operating systems are installed in UEFI mode, not legacy.

What I've tried

  • Reinstall Ubuntu (several times)
  • Try a different image (I've tried 18.04 LTS versions of Mint and Xubuntu)
  • Try a different Live USB creation software (UnetBootin and UUI)

I'm not used to debugging problems like this --- I'll try to diligently answer any questions that may help you provide an answer for me.

(uninstalling Windows completely is not an option)

0

The issue was eventually solved by re-partitioning the disk without boot partition, which I had made out of habit without. After re-partitioning, the install went through flawlessly and the system booted as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.