I'm trying to install 18.04 using my iGPU with the intention of using my dedicated GPU for GPU passthrough. Currently I'm just at the stage of trying to get Ubuntu just to work with my iGPU on the i5 6600K.

First time round I installed with just my RX480 as my primary gpu, the install went smoothly and everything was fine. I changed my primary gpu to the iGPU and instead of the Ubuntu splash screen I instead see the checks being done in the background, the screen flashes 4 times or so and then I get to the login screen (even though I had enabled auto-login). I enter the password, it looks like it is about to take me to the desktop, but it puts me back to the login screen.

I then thought that maybe I needed to install Ubuntu with the iGPU as the primary device, the first time round I started getting errors about holding bad packages and errors writing to virtual memory. So I tried again, this time removing the overclock from my CPU thinking it might be that. The install went perfectly until I had to reboot, then I got taken to the login screen but the screen is all torn and everything is illegible. I switched the primary device back to the dedicated GPU, and it boots up perfectly and the image is displayed properly.

I have tried adding GRUB_GFXPAYLOAD_LINUX=1920*1080 to my grub file which did not work and I tried updating xserver-xorg-video-intel but was told I had the latest version and I'm struggling to work out what is wrong and just getting ready to give up on this project.

If it helps at all my system specs are:

i5 6600k


RX 480 8GB

MSI Z170 Krait Gaming 3x

If anyone can help I'll love you forever and if you need me to provide any info please let me know what you need.

  • My understanding is that GPU passthrough is a fairly cutting edge thing at the moment. These guys seem to be pushing this forward with good success: forum.level1techs.com/search?q=gpu%20passthrough – hmayag Aug 6 '18 at 18:27
  • @hmayag Yeah, I plan to follow their guide once I can get the integrated GPU working with the OS first as that is causing me the most trouble right now. – Tom Williams Aug 6 '18 at 18:30
  • I have the same exact problem that I described here yesterday – dadexix86 Aug 6 '18 at 18:54
  • Not sure if it makes a difference but I use 1920x1080 not 1920*1080. – WinEunuuchs2Unix Aug 7 '18 at 0:16

If I understand correctly, your first wish is to run on the IGD exclusively, then sort the remaining issues. The following steps should achieve the first goal to increasing degrees of thoroughness.

Check for improvement after each step, and stop when it works. Don't needlessly blacklist the kernel modules, as this could mean the discrete card won't be powered down. In fact, you may want to swap steps 3 and 4.

1. Configure Xorg to prefer the Intel

Create file /etc/X11/xorg.conf.d/10-intel.conf (this may require mkdir /etc/X11/xorg.conf.d), containing:

Section "OutputClass"
   Identifier "Intel"
   MatchDriver "i915"
   Driver "intel"

2. Disable modeswitching out of IGD

Edit /etc/default/grub and add xdg.force_integrated=1 to GRUB_CMDLINE_LINUX_DEFAULT. When done, run sudo update-grub before rebooting.

3. Blacklist the nouveau kernel driver

Edit /etc/default/grub and add modprobe.blacklist=nouveau to GRUB_CMDLINE_LINUX_DEFAULT. When done, run sudo update-grub before rebooting. (For AMD blacklist radeon, amdgpu, etc..)

4. Uninstall the Xorg nouveau driver

sudo apt remove xserver-xorg-video-nouveau  # or radeon, amdgpu ...

This will trigger removal of the xserver-xorg-video-all meta-package, which by default is installed. That is alright, but you may want to keep xserver-xorg-video-intel installed (but see update below):

sudo apt remove xserver-xorg-video-all
sudo apt install xserver-xorg-video-intel

Update 2019 the package description for xserver-xorg-video-intel now recommends against installing the package. It should only be needed on old (pre 2007) hardware.

Note: this is an edited copy of my answer to this question, which may have useful pointers for your follow-on steps, as it is about resolving issues with the discrete card.

  • 1
    You sir, are a goddamn legend. The first solution worked like a charm and now I have other solutions to fall back on if this fails. – Tom Williams Aug 7 '18 at 18:25
  • Great to hear! On AskUbuntu, don't use the comments to say "thanks". That's what the upvote and accept buttons are for. – zwets Aug 7 '18 at 19:35
  • Tried this solution in relation to this question and it didn't work. – realkstrawn93 Sep 27 '18 at 2:20
  • 1
    Thank you so much. This stopped the cursor flickering in my browser (Brave) on Dell XPS 13 9370. – forgetso Nov 21 '18 at 18:46

The above solution didn't work in my case, I solved the problem by purging the nux-tools:

sudo apt purge nux-tools

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.