0

Update manager does not show version 18.04 as upgradable, and from the console I write update-manager -d and it answers "Gtk-WARNING **: cannot open display: :0 No protocol specified Unable to init server: Could not connect: Connection refused". I use version 17.10

What can I do?

3

1 Answer 1

0

I solved the problem. Thanks, Norbert, Karel and K7AAY. In fact I did everything you told me, and one of your solutions worked, though I am not sure which one did. My problem was related to the graphic system, gtk, so the upgrade worked in console mode.

I'm grateful to you all, because your answers made me think! :-)

1
  • Ubuntu 17.10 defaulted to Wayland (instead of X11 or Xorg/Xserver). Wayland (for security purposes) prevents many processes from accessing your GUI which X11 allowed. Thus many tools (like gksudo) were depreciated as they don't work on Wayland; your using a console meant you had no gui running and it didn't try and write to X11. You could have logged out, and logged back in with Gnome with Xorg and it would have worked. Ubuntu 18.04 LTS uses Xorg by default due to users have issues like you did.
    – guiverc
    Feb 5, 2019 at 23:30

You must log in to answer this question.