3

I'm on Ubuntu 18.04 with GNOME, and I'd like to use use fcitx instead of iBus because I usually type East Asian languages. I installed the fcitx package, went into Language Support, and changed "keyboard input method system" to fcitx. However, after I reboot, I still get the iBus input method menu. How can I finally get rid of iBus and switch fully to fcitx?

(Please do not convince me to stay with iBus; Sun Pinyin and ibus-mozc are virtually unusable.)

1

I have also encountered such a problem. The root cause is that Ubuntu switch to GNOME since 17.10 and GNOME may not support fcitx well at present. The following scripts may be helpful to you:

Step 1 check fcitx be installed

sudo apt install fcitx fcitx-mozc

Step 2 open ~/.pam_environment with your text editor and set the following environment variables to start fcitx

XMODIFIERS DEFAULT=@im=fcitx
GTK_IM_MODULE DEFAULT=fcitx
QT_IM_MODULE DEFAULT=fcitx

Step 3 add an autostart entry to start fcitx. Search "Startup applications Preferences" in Ubuntu Activities and add an entry for fcitx

Name: Fcitx
Command: /usr/bin/fcitx-autostart
Comment: type your favorite description for fcitx

Step 4 reboot and check if fcitx wake up

See more details in this document: https://www.csslayer.info/wordpress/fcitx-dev/how-to-use-fcitx-on-ubuntu-17-10/

  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Kevin Bowen Sep 11 '18 at 3:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.