1

I have an external USB drive that I use for rsnapshot backups. Under 16.04.x it was detected as a USB drive and automatically mounted at /media/usb0, so I configured rsnapshot to use that as its backup target.

After upgrading to 18.04.1, the USB drive has magically become /dev/sda (which had been the internal hard disk in 16.04.x) and is no longer mounted automatically at boot, resulting in rsnapshot failures. I "fixed" the problem by adding the UUID for /dev/sda1 to /etc/fstab and having it mounted at /media/usb0, but this doesn't "feel" like a correct solution.

Can anyone help/explain why 18.04.1 now (a) finds the USB drive before the internal drive and most importantly (b) no longer automatically mounts the USB drive at /media/usb0 as 16.04.5 had been doing?

FWIW, I have found that this happened on 2 of the three machines I have that boot with a USB drive attached. On the third machine, it works exactly as it did in 16.04.5. The 2 that show this behavior are both physically tiny (500GB) Seagate drives that are powered by the USB port. The other has two La Cie external drives with their own external power. All three computers are different hardware, one custom built, one dell server, and one gateway -- the gateway is working normally.

In reality, I don't expect to ever find out why this behavior changed, but I can always hope.

  • 1
    That is actually quite normal for it to detect USB drives before onboard drives. The /dev/sd* designation really has no meaning in the way the system boots as long as the UEFI or BIOS (Legacy) sees the correct booting drive. And USB drives still detect as /dev/sd* because they are still a block device like internal hard drives are. – Terrance Aug 6 '18 at 12:16
  • OK. I guess my "issues" are: (1) /dev/sda seems like a bad name for a REMOVABLE device (to me) and (2) USB drives have always mounted automatically at /media/usbN in the past, so why the change (a) first detected device and (b) no longer mounting when discovered? – Steve Valliere Aug 6 '18 at 13:05
  • The /media/ folder is used for the mount points only and not the /dev/sd* designation. Whether they be automatically mounted or manually mounted the /media/ folder is where they go or they should go especially if you want them on your desktop. The /dev/ folder is used for all devices and should no ever be touched by the user themselves. Setting up something in the /media/ folder helps so that programs like Plex Media Server can always find the mount of the data regardless of what the /dev/sd* is showing for the drive. – Terrance Aug 6 '18 at 13:18
  • I understand WHAT the /media folder is used for. I don't understand WHY Ubuntu 18.04.1 has decided to STOP mounting the USB drive it discovers in the /media location as 16.04.x had been doing. (I also don't understand why the USB drive is discovered BEFORE the internal hard drive, but that is a different question, I suppose.) – Steve Valliere Aug 6 '18 at 13:51
  • I think this is a good and reliable solution: 'I "fixed" the problem by adding the UUID for /dev/sda1 to /etc/fstab and having it mounted at /media/usb0, but this doesn't "feel" like a correct solution.' (Automatic recognition and mounting of partitions is less reliable.) – sudodus Aug 8 '18 at 12:44
0

I am answering this myself, just to have the best solution available clearly shown with the question.

It seems that my work-around of discovering the UUID values for the USB devices I want mounted at boot and manually adding them to /etc/fstab is the best solution to this issue.

As for why the discovery and mounting of external USB drives is different with some hardware and not with others (all running Ubuntu 18.04.1 x64) seems to be unknown.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.