3

In 18.04, Software & Updates won't let me select/deselect repositories/PPA's in the "Other Software" tab.

However, if while in terminal I type:

sudo software-properties-gtk

I am able to select/deselect repositories/PPA's in the "Other Software" tab.

Anybody have suggestions on where to look for a problem, or a fix?

Update #1:

At the login screen, if I select GNOME or Unity, then it all works fine. If I select GNOME on Xorg or Ubuntu, it doesn't work. Also, if I start Synaptic, which asks for the admin password after launch, it all works fine too.

  • Are using Gnome Desktop or Unity Desktop? – WinEunuuchs2Unix Aug 5 '18 at 19:05
  • @WinEunuuchs2Unix GNOME – heynnema Aug 5 '18 at 19:24
0

This happened to me and in my case it was due to some errors in Gnome (if you are using it). Basically when you click any repository the "asking for password" popup should appear, but at times it didn't show. So it was asking for the admin password but you could not see that. Therefore you could not select anything. It was hidden somehow and only after pressing Alt+F2 then r and enter (to restart gnome) I could see the popup and then everything worked.

Basically when you go to Software and Updates and click a repository and nothing happens, just restart Gnome and see if it works. It does for me.

  • 2
    Good suggestion, but it seems that I don't have the same problem/fix. – heynnema Aug 5 '18 at 19:51
0

I found this article, 21 Best things to do after installing Ubuntu 18.04. From it this advise:

2. Enable Additional Repositories

Ubuntu doesn’t come, by default, with enabling additional repositories. Before updating and upgrading your Ubuntu system must allow the additional canonical repositories. To do so, search for software & update. In the other software tab, enables “Canonical Partners.” Now close the window, ignore if it says reload.

Disagreeing with the author a bit, when it says it wants to reload and asks for admin password, I have the habit of complying.

Also a bonus picture :):

enter image description here


Another Option to try

If memory serves me correctly I ran into a similar problem with Ubuntu 16.04 under Unity but can't say for sure. If the author's recommendation doesn't fix the problem, then in the picture above click on the preceding tab Ubuntu Software. Now eusure the options for (universe) and (multiverse) are checked.

  • Thanks for the help! I checked the settings of "Canonical Partners" and the universe and multiverse options, and they're set fine. I did notice that if change any options on the "Ubuntu Software" or "Updates" tabs, it does ask me for the admin password... although just changing anything on the "Other Software" tab doesn't ask for the admin password... and also, even though the checkmark doesn't change, it does ask to update the database when I close the window. – heynnema Aug 5 '18 at 20:04
  • The password is only required when it wants to run sudo apt update in the background. This also happens if you add or remove a PPA I believe. – WinEunuuchs2Unix Aug 5 '18 at 20:14
  • I think that's part of the problem. It's not asking for the password when I make any changes on the "Other Software" tab, or when it asks me to update the database. I just tried reinstalling "Software & Updates", but it didn't help. – heynnema Aug 5 '18 at 20:17
  • Please see my update #1 in my question. Thanks. – heynnema Aug 6 '18 at 2:34
  • @heynnema I read your update and you mention where it works fine. You neglected to mention where it doesn't work fine :) – WinEunuuchs2Unix Aug 6 '18 at 2:43
0

A workaround for this problem...

  • start Synaptic
  • enter the admin password
  • choose Repositories from the Settings menu
  • enable/disable/edit repositories as desired
  • close the window when done
  • click the Reload button after closing this window
0

I recently ran into this problem in 18.10 which comes default with the Gnome desktop.

I ran sudo update-manager from the terminal which allowed me to select/deselect additional providers without needing the pop-up to show up.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.