1

My RAM management problem started from Ubuntu 17.04. I was only using Firefox(6/7 tabs) and the terminal eats up about 3.5 GB of RAM...

I've tried changing the swappiness value to 10, but it doesn't improve the condition...It just delays the lagging...Also followed some tips from the community and different blogs, but no improvement...

Is there any fix for this lag issue?

My laptop's specs are:

  • Intel Core i3 6th generation
  • 4 GB RAM
  • 500 GB HDD
  • What brand/model system. Some need boot parameters. But RAM should fill up with each application you use. It only releases unused application space when another app needs it, since we often reuse same app and then it still is in RAM. Difference between Details screen on RAM and free command askubuntu.com/questions/743649/… – oldfred Aug 5 '18 at 18:42
  • My laptop brand is walton passion wp156us.I've run the commands from the thread you've mentioned already..The free -h command shows me something like this- pastebin.com/8DrPgLdT is that normal? p.s-sorry for the external link,I'm unable to insert new line inside it – Abir Partha Aug 6 '18 at 11:05
  • Yes that is normal. But a bit suprised with 4GB of RAM, you used even the 68MB of swap. My older system was 4GB and I do not think I ever used any swap. My old laptop with 1.5GB of RAM regularly used swap if I tried to load several larger apps at once. I could tell immediately as screen went grey (not refresing) for several seconds. Learned not to load too much at one time. – oldfred Aug 6 '18 at 15:28
  • The log I took was taken after a reboot.Usually when I'm using sublime with firefox(I can't use any ide on ubuntu due to this extreme lag),my os uses about 500 mb -1 gb of swap memory.As far as I know,using swap memory increases lagging.So I tried to set my swappiness to 0.But then downloading a file from mega(only one tab in firefox) would freeze my whole system.Should I reinstall the os?I'm currently using ubuntu on dual boot with windows(legacy bios,my laptop doesn't seem to support uefi) – Abir Partha Aug 7 '18 at 6:11
  • With core i3 and 4GB of RAM, you should not be having issues. And if core i3, it is UEFI, some vendors still call it BIOS. But converting/re-installing Windows now is a big task, so probably best to stay with MBR. But system should not be that slow, my Core2 Duo was older/slower with 4GB and never had issues.Not familar with your system (never seen it before), so it may need a boot parameter or some setting in UEFI/BIOS. Are you using the 64 bit version of Ubuntu? Is something running in background? Check with top or install htop. – oldfred Aug 7 '18 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.