3

This exact same question was asked here but the community missread and marked inacurately as a duplicate.

fingerprint-gui and 18.04 login issue

I am also NOT asking HOW TO install. I am asking asking the same as the user!

ubuntu 16.04 fingerprint-gui was working great just 1 hour ago.

I've upgraded to a fresh clean install of ubuntu 18.04 followed the link below to install fingerprint gui but i can confirm that the same behavour the user above is facing i too am facing. all of my /etc/pam files have referenced gdm authentication and not lightdm as used before. i can use the fingerprint scanner with any terminal sudo//su command. However it does not work for pam authentication or gdm. Has anyone found a solution yet?

fingerprint-gui and 18.04 packaging issue

  • Indeed, with Ubuntu 18.04, i can log in with a fingerprint on a virtual console in text mode, but not with GDM3. – Alexey Jan 10 at 15:26
  • Do you absolutely need Fingerprint-GUI, or FPrint would be enough? I've currently removed Fingerprint-GUI and do not feel like to install it back to test with. – Alexey Feb 1 at 12:56
1

Ubuntu 18.04 minimum dist comes with gdm3 pre-configured when you perform a clean install. While the docs here FingerpringGui Docs Do say its 18.04 compatible i have been having issues trying to get it to login in using a fingerprint hiding the user login and using the finger to find user and password. (This is risky to do so don't do it unless you can be sure it works)

After trying many different options i finally came to the solution on just removing gdm3 and installing lightdm.

sudo apt install lightdm

when asked which should be the default display manager select lightdm

There is no need to reinstall fingerprint-gui just open click on the settings tab and verify that

a) lightdm, gnome-screensaver, sudo and su are not greyed out. b) Check all the tests pass.

You should now be able to use the fingerprint scanner for all of the above.
If you test lightdm or gnome-screensaver and you get ok, but the test button is grayed out. Don't panic hit enter.

Restart your computer and voila.

With 18.04 for now I would wait before removing the login inputs and using the fingerprint-gui, 1 to many function that helps to find a user and password.

  • Works on my HP Elitebook 2730p finally!!!! – meaje Oct 19 '18 at 22:03
  • Worked on my Clevo P150EM on 18.04.2 LTS sudo was fine with fingerprint but there was never any option in the Users Settings to enable fingerprint login. But after doing this, and restarting the computer, I am able to use my fingerprint to login. But still there is no option in User settings Thanks – ryan2johnson9 Mar 19 at 1:38
  • When you say option are you reffering to the users acount in the default ubuntu settings. If so thats not how its handled. fingerprint gui handles all the login with fingerprint. you can remove the password login all together. if you goto ulbricht site it has a tutorial on its site for this perpose. The reason i use fingerprint-gui and not fprint is due to this ability of switching off passwords having many users and many fingerprints – scope Jun 25 at 6:44
0

This answer does not match the question precisely because I am not currenlty using Fingerprint-GUI, but otherwise I've managed to get fingerprint authentication to work with GDM.

I've installed FPrint from the PPA with

sudo apt-get install libfprint0 libpam-fprintd

(fprint-demo is not necessary.)

I've also experimented with Fingerprint GUI, but ended up by uninstalling it as redundant and somewhat buggy (there were issues).

At first I could not use fingerprint authentication with GDM, but now it works. I suppose that I've got it fixed by executing

sudo pam-auth-update

and checking the checkbox "Fingerprint authentication."

  • This is an ok option but you have less features as i believe fprint does not allow a passwordless login like fingerprint-gui (I am more than likely wrong here) But it i could never get it to work with many users and many fingerprints with zero password. – scope Jun 25 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.