I am using Ubuntu 18.04.1 LTS (updated 2 days ago from 16). The resolution was fine, but accidentally it changed to 1024x768 (4:3) and every time when i am trying to change to 1920x1080 (or any other size) it not accepted and return to 1024x768 (4:3). Please help me, thank you.

Image 1

Image 2

Image 3

Tried several times, restarted pc, but no changes applied. Please help:)

Edit: Added screen from the terminal with existing resolutions: Terminal


First check your monitor code


Check your device code

sudo lspci |grep -i vga

i solved this problem by configure xorg the solution is creating configuration file in /etc/X11/xorg.conf.d/10-monitor.conf

The 10-monitor.conf should be contain the configuration like this:

Section "Monitor"

    Identifier  "Monitor0"`


Section "Device"

    Identifier  "Device0"`

    Driver      "radeon" 


Section "Screen"

    Identifier "Screen0"  #Collapse Monitor and Device section to Screen section
    Device                 "Device0"
    Monitor                "Monitor0"
    SubSection             "Display"
        Depth              16
        Modes              "1920x1080_60.00" #Choose the resolution




Check if "nomodeset" is added in your grub. (Like in my case)

goto /etc/default/grub

If yes remove it.

Run command after saving file

sudo update-grub

and reboot the system

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.