0

I'm using Ubuntu 16.04 on Dell Vostro.

I have a problem to use external hard drive. When I plug it, first it works, but in some time it unmount by itself (while reading data or not).

While the drive was mounted, I tried to open GParted, got the warning input/output error during read on /dev/sdb, and had to kill the process in the terminal.

I tried to use smartctl, but it failed:

$ sudo smartctl -a dev/sdb | less
dev/sdb: Unable to detect device type 
Please specify device type with the -d option.

First I thought that the external drive is broken, but I've tried with another one, I was also trying to change the USB cable and the behavior is exactly the same.

I still can see the drive in Nautilus, but I can't open the folder (Unable to access location. Can't mount file) and I can't see it with lsblk command.

I use the USB ports with my phone without any issues, so I assume that they're fine.

I've run dmesg in terminal. The output is long, I'm pasting only the lines which point to errors:

[   22.055520] usb 2-1.5: device descriptor read/64, error -110
[  776.281556] sd 6:0:0:0: [sdb] Write Protect is off
[  776.281563] sd 6:0:0:0: [sdb] Mode Sense: 28 00 00 00
[  776.281881] sd 6:0:0:0: [sdb] No Caching mode page found 
[  776.281899] sd 6:0:0:0: [sdb] Assuming drive cache: write through 
[  776.308840]  sdb: sdb1
[  776.309940] sd 6:0:0:0: [sdb] Attached SCSI disk 
[ 5113.058945] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A 
[ 5113.059011] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH  transcoder A FIFO underrun

I didn't find what error -110 means.

UPDATE 2:

Thanks to the comment I've managed to run smartctl. There is part of the output of smartctl -a /dev/sdb | less:

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Short offline       Completed without error       00%      8872         -
# 2  Extended offline    Completed without error       00%      8872         -
  • 1
    To format terminal output, don't use a blockquote (or > at the start of the line). Instead, select the terminal output in the question editor with your mouse and then click on the {} button in the question editor (or add four spaces to the start of each line). – Chai T. Rex Aug 8 '18 at 20:41
  • 1
    Also, sudo smartctl -a dev/sdb has a small problem: the disk's filename is /dev/sdb with a / on the front and that small change of not including the / is enough to make things not work out right. Please try the command again with that fix (sudo smartctl -a /dev/sdb | less) and put the results into the question. – Chai T. Rex Aug 8 '18 at 20:53
  • @ChaiT.Rex Thanks for the tip, indeed it worked with /, but the output is quite long. I'm pasting only the part resuming the tests results (which I've run before), in update 2. – maria Aug 10 '18 at 18:34
  • SMART tests are run by the hard drive itself without the participation (except for starting the test at the beginning) of the operating system. Since you had an extended SMART test pass, the hard drive itself is probably fine internally. Something is probably wrong with its connection to your computer or its connection to power. – Chai T. Rex Aug 10 '18 at 21:00
0

Input/output errors are most often caused by hardware issues. These can be as simple as a loose cable, all the way up to and including a failing disk device.

Since you indicated that the disk device is sometimes not detected, the problem does seem to be hardware related. If a new USB cable does not work, then you might also try a different USB port, or a different computer.

When an error occurs, you can also run the dmesg command to learn more about the disk device error.

  • RE: Update 2: To determine the drive health one needs to look at all the smartctl output. Often when I have a drive start to fail I begin seeing non-zero values in Reallocated_Sector_Ct. – Curtis Gedak Aug 23 '18 at 17:21
  • Finally I've reinstalled the system. The drive was fine while I was using it with live session, so since I was not able to determine what's going on, I've decided to install new system. Should I remove the question? – maria Aug 24 '18 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.