5

Whenever I try to install phpmyadmin on my ubuntu server 18.04 I get the following errors

sudo apt install phpmyadmin php-mbstring php-gettext
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package phpmyadmin
E: Unable to locate package php-mbstring
E: Unable to locate package php-gettext

Most threads I ca find suggest reupdating and upgrading using apt, but doing so doesn't do anything, also I get that error on the fourth line

Err:5 http://ppa.launchpad.net/nijel/phpmyadmin/ubuntu bionic Release
  404  Not Found [IP: 91.189.95.83 80]
Hit:6 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:7 http://download.webmin.com/download/repository sarge Release
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/nijel/phpmyadmin/ubuntu bionic Release' does not have a Release file.

Can someone help with this?

2

3 Answers 3

14

This worked for me:

sudo add-apt-repository universe

Then:

sudo apt install phpmyadmin
2
  • 1
    I had the same problem but installing xrdp, your solutions works great with this issue too Sep 14, 2018 at 19:18
  • This worked best for me to get phpmyadmin installed. Would recommend as the best answer.
    – Max Kulik
    Sep 26, 2018 at 4:58
5

Your ppa doesn't serve phpmyadmin for bionic version. You should remove ppa first:

sudo add-apt-repository --remove ppa:nijel/phpmyadmin
sudo apt update

then run your command again

sudo apt install phpmyadmin php-mbstring php-gettext
5
  • 2
    Still same issue, unable to locate it Aug 5, 2018 at 10:39
  • have you try sudo apt dist-upgrade when upgrading?
    – eR_
    Aug 5, 2018 at 13:22
  • Didn't work for me, I got a "The user named '~nijel' has no PPA named 'ubuntu/phpmyadmin'" - I had to manually remove the reference file /etc/apt/sources.list.d/nijel-ubuntu-phpmyadmin-xenial.list
    – n.r.
    Apr 26, 2019 at 9:57
  • Check your /etc/apt/sources.list.d/ and remove the file for phpmyadmin
    – Maziyar
    May 2, 2019 at 12:10
  • you write sudo apt install phpmyadmin php-mbstring php-gettext <-- I think now with Ubuntu 20.4 you just need sudo apt install phpmyadmin. 'cos php-gettext equivalent is installed with php. And php-mbstring is installed with phpmyadmin.
    – barlop
    Jan 9, 2021 at 18:54
-2

I have precisely the same issue. Tried sudo apt install phpmyadmin (with and without php-gettext and php-mbstring which I installed separately as I am using php7.1) but always get E: Unable to locate package phpmyadmin

and for the add-add-repository

E: The repository 'http://ppa.launchpad.net/nijel/phpmyadmin/ubuntu bionic Relea se' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disa bled by default.

Also tried downloading the package from a mirror but got nowhere with that either.

Is the ppa broken and is there another solution or workaround or something I can do to help resolve this issue?

1
  • Please ask your own question
    – damadam
    Aug 17, 2018 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.