I have been using the following to access files on a another PC on my desk and it has been working just fine for more than a year. I did an Update and Upgrade today and now I cannot Paste into the mounted Folder. I tried to change ownership from root to the username to see if that fixes the problem, but it stays at root.

I can access the files and copy from the mounted Folder but not add anything in to it.

Could someone please help me get back the access I once had?

sudo mount -t cifs -o username=xxxxxx,password=xxxxxx //192.168.10.10/arduinoIDE /media/arduinoIDE

  • Can you paste the output of ls -la /media and the output of ls -la /media/arduinoIDE – hatterman Aug 5 at 1:20
  • @hatterman: Thanks, I was about to do that, but then I read Morbius1's approach and that seems to have solved the problem. – X10WannaBe Aug 5 at 15:21
up vote 1 down vote accepted

3 possibilities:

[1] The server changed the share definition of [arduinoIDE] to allow read only access to the username / password you are sending.

[2] The server changed the permissions of whatever directory the [arduinoIDE] share points to allowing only read access to username / password.

[3] This one depends of what OS is running on the server but if it is Linux try this as your mount command:

sudo mount -t cifs -o username=xxxxxx,password=xxxxxx,uid=morbius,nounix //192.168.10.10/arduinoIDE /media/arduinoIDE

Change morbius to your Linux local login user name.

  • Thanks, that seems to have done the trick. I should have mentioned in the OP that both PCs are running 16.04. – X10WannaBe Aug 5 at 15:22

I suspect your permissions on /media changed, so /media/arduinoIDE is owned by root. Updates will sometimes do that. They expect you to put things mounted for particular users within /run/media/username, place used by Gnome and Xfce gvfs mounters.

For whatever reason, the person who runs the samba server here has it set so users cannot change permissions or ownership on Linux clients. I am told that even if I try ACL it won't help. I wonder if your windows server changed.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.