14

I'm trying to install wifi drivers for a particular mini wifi card i bought. The output of lsusb is:

0bda:f179 Realtek Semiconductor Corp

I've searched everywhere for drivers, but could not find anything. Any help?

Thanks

6
  • I don't believe there is any new information since @Jeremy31 's comment here: askubuntu.com/questions/1008669/… Sorry.
    – chili555
    Aug 4, 2018 at 18:43
  • yea i saw that. Are there no other alternatives? Any other drivers?
    – shroomed12
    Aug 4, 2018 at 18:46
  • None that either @Jeremy31 nor I have been able to find. I suggest that you temporarily use a USB wireless and check back in a few months. I wish we had a better answer. PS - I hope I will not appear too blunt, but if Jeremy31 can't find it and if I can't find it, the chances are quite high that it doesn't yet exist.
    – chili555
    Aug 4, 2018 at 19:58
  • oh okay. Thanks for the response. I currently have a usb one which is using the 0bda:f179 chip. Any other mini wifi usb cards you know that work well with ubuntu (17) ?
    – shroomed12
    Aug 4, 2018 at 20:59
  • Please see my post #22 here: ubuntuforums.org/…
    – chili555
    Aug 4, 2018 at 21:09

9 Answers 9

11

You can install rtl8188fu driver with dkms via this repo (has install instruction).

3
  • 2
    * I followed the CLI instructions provided from the repository's README.md file and it worked. PLEASE NOTE: I had to phycially unplug and plug the device back. Alternative provided, i.e., to use the .deb packages did not work for me. May 10, 2019 at 12:19
  • Thanks a lot @Butterfly. Those instructions indeed worked for me.
    – Puspam
    Feb 22, 2020 at 15:48
  • Thanks a lot @Butterfly. Work from home is now on with Wifi rather than USB Tethering.
    – Hanry
    Mar 25, 2020 at 4:59
7

@Butterly's answer worked for me. But I will write out the steps here to make it clearer for others (copy/pasted from https://github.com/kelebek333/rtl8188fu):

For Kernel 4.15 ~ 4.20 (Linux Mint or Ubuntu Derivatives)

sudo apt-get install build-essential git dkms linux-headers-$(uname -r)

git clone https://github.com/kelebek333/rtl8188fu

sudo dkms add ./rtl8188fu

sudo dkms build rtl8188fu/1.0

sudo dkms install rtl8188fu/1.0

sudo cp ./rtl8188fu/firmware/rtl8188fufw.bin /lib/firmware/rtlwifi/

After you are done, reinsert the wifi dongle and if you ifconfig, you should now have a new device present.

2
  • 1
    Worked! I can see the adapter in the WiFi settings now, and networks to join.
    – apkg
    Nov 21, 2019 at 9:20
  • If you have a 64-core machine: export MAKEFLAGS='-j 64' will make the compilation faster.
    – Ole Tange
    Jan 29 at 9:23
5

Finally! We do have a native Linux driver for 0bda:f179 RTL8189FTV! The only thing is that it needs some expertise to use (and Internet).

The driver is not mainline, so Ubuntu and derivatives do not have it.

The driver is here. Its called rtl8188fu.

Download the entire repository as zip. Then, in the Makefile, add -Wno-error=date-time as an EXTRA_CFLAGS. Basically, add the line:

EXTRA_CFLAGS += -Wno-error=date-time

Then, compile with make. After successful compile, you will get: 8188fu.ko then (as root) do:

insmod ./8188fu.ko

That's it. It will work now. I have compiled it for 16.04 LTS (4.4.0-138-generic), so the compatibility of the driver is pretty good.

The situation regarding 18.04 is slightly complicated, as the driver hasn't been updated for over an year.
I have made changes to the driver to work with 18.04 4.15.0-38 kernel, and it works.

Output of uname -a:

Linux theoraxpc01-Veriton-Series 4.15.0-38-generic #41-Ubuntu SMP Wed Oct 10 10:59:38 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Output of usb-devices (on 18.04):

T:  Bus=02 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#=  3 Spd=480 MxCh= 0     
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1     
P:  Vendor=0bda ProdID=f179 Rev=00.00     
S:  Manufacturer=Realtek     
S:  Product=802.11n          
S:  SerialNumber=00E0252CB0BF
C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=500mA     
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=rtl8188fu   

I have uploaded both the module and the fixed drivers on my Google Drive. The module will work for 4.15.0-38-generic and this is the kernel against which I have compiled the source.

9
  • this didn't work for me. I've the following kernel - 4.15.0-39-generic any other suggestion?
    – nEO
    Nov 22, 2018 at 7:16
  • @nEO You mean you have 18.04 LTS? I have that on one system as well. I had to make a lot of changes to the driver to make it work. If you want, I can share the source code with you, or otherwise I can also share just the module.
    – Domo N Car
    Dec 5, 2018 at 15:21
  • hey @Domo - I have 16.04. Will this work on my machine then. Do share the code. I kind of gave up on that.
    – nEO
    Dec 7, 2018 at 23:40
  • @nEO, Yes, it will work on 16.04 as is (download from github link I gave). As for the code for 18.04, it is me hacking the code to be compatible with 18.04. I will share the zip tomorrow.
    – Domo N Car
    Dec 9, 2018 at 10:24
  • 1
    @nEO I have uploaded both the module and the fixed drivers on my google drive. The module will work for 4.15.0-38-generic and this is the kernel against which I have compiled the source.
    – Domo N Car
    Dec 24, 2018 at 17:35
1

As of the date of this answer there is no support for the 0bda:f179 Realtek WiFi adapter. You would likely be better off obtaining a natively supported device.

There's a list of WiFi adapters supported by the kernel here that you might find useful.

There's also a query page where you can check to see if your device has kernel support.

Edit: Realtek PCI ID is 10ec, their USB ID is 0bda so if you find a driver that supports 10ec:f179 that might be worth trying.

If you have a Windows driver for the device you could also try using ndiswrapper.

1
  • @Zanna Glad to help! :)
    – Elder Geek
    Aug 8, 2018 at 21:10
1

Finally The Driver installation process for USB DEVICE 802.11 bgn which looks like Realtek Semiconductor when done lsusb uses RTL8188fu drivers and proper installation procedure is found at rtl8188fu linux driver for wireless bgn device.

There is no need to reboot. Thanks a lot

1

I've tried in my Debian Strech Kernel 4.9.0-6-amd64 and after the build and install from this repo the dongle can find networks, but can't acomplish connections.

So, in order to fix this issue, I've changed Makefile to disable powersaving and enable monitor mode (because i've needed, not sure if this have something to do with the issue) on lines 40 and 61 like that:

$ ./rtl8188fu/Makefile:

CONFIG_POWER_SAVING = n
CONFIG_WIFI_MONITOR = y

Now works fine.

So, for Debian Strech kernel 4.9.0-6-amd64:

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install build-essential git dkms linux-headers-$(uname -r)

git clone https://github.com/kelebek333/rtl8188fu

sudo dkms add ./rtl8188fu
sudo dkms build rtl8188fu/1.0
sudo dkms install rtl8188fu/1.0
sudo modprobe rtl8188fu

I hope can help someone facing this problem.

Thank you!

1
  • After spending hours, Finally above answer worked for me on Ubuntu 18.04 Mar 23, 2020 at 10:10
0

I was facing same problem for my 802.11n adapter. The following link worked for me.

https://github.com/kelebek333/rtl8188fu

0

Installing the driver from kelebek333/rtl8188fu repo helped me identify the network device. After installation, eject and reconnect the usb wifi adapter, and then check:

sudo lshw -c network

You will see something like this:

  *-network
       description: Wireless interface
       physical id: 2
       bus info: usb@1:12
       logical name: wlx1cbfcef96282
       serial: 1c:bf:ce:f9:62:82
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8188fu ip=192.168.1.2 multicast=yes wireless=IEEE 802.11bgn

Then you are good to go.

0

i found an answer and fixed the issue. I was trying to install another wireless adapter and fixed the broadcom wireless issue.

[https://www.tecmint.com/sub-process-usr-bin-dpkg-returned-an-error-in-ubuntu/][1]

2
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Feb 2, 2021 at 23:28
  • I did include a link but it didn't link the page [tecmint.com/… Feb 4, 2021 at 0:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.