25

I have installed Ubuntu 18.04 on a Surface Book with dual boot, and I can't get the ethernet connection to work. Although the wifi connects, I keep getting the "activation of network connection failed" error for the ethernet.

sudo lshw -C network gives me:

  *-network                 
       description: Wireless interface
       product: 88W8897 [AVASTAR] 802.11ac Wireless
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 00
       serial: 98:5f:d3:45:f8:58
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=mwifiex_pcie ip=192.168.1.189 latency=0 multicast=yes wireless=IEEE 802.11
       resources: irq:133 memory:b9500000-b95fffff memory:b9400000-b94fffff
  *-network
       description: Ethernet interface
       physical id: 1
       logical name: enxc49dede69606
       serial: c4:9d:ed:e6:96:06
       size: 10Mbit/s
       capacity: 1Gbit/s
       capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.09.9 duplex=half link=yes multicast=yes port=MII speed=10Mbit/s

But I suppose this is not near enough information to investigate. Please let me know what else is useful to know in this case, and I'll add that to the question.

PS: I saw this question, but I have all the updates installed, and I still can't connect, so this is not a duplicate.

UPDATE: Before turning off the computer, I turned off the cable connection in Settings. Today when I turned it on, the ethernet button is gone: enter image description here

Running journalctl gives this: https://gist.github.com/sedulam/b37515fc90ab41a6d1c88a951baf11f6

ip ro gives this:

default via 192.168.1.254 dev wlp3s0 proto dhcp metric 600 
169.254.0.0/16 dev wlp3s0 scope link metric 1000 
192.168.1.0/24 dev wlp3s0 proto kernel scope link src 192.168.1.195 metric 600

systemctl gives: https://gist.github.com/sedulam/77d905dc3ecdf379a785b0694e23ed3e

ps aux | egrep wpa\|conn gives:

root      1037  0.0  0.0  45016  7504 ?        Ss   21:16   0:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
pedro     3460  0.0  0.0  21536  1088 pts/0    S+   21:21   0:00 grep -E --color=auto wpa|conn

service --status-all gives: https://gist.github.com/sedulam/ae85b271a24aecdd3f04f920df2059e9

Surface Book model: Microsoft Surface Book 13.5 inch Touchscreen Laptop (Intel Core i7-6600U 2.6 GHz, 16 GB RAM, 512 GB SSD, NVIDIA 1 GB Integrated Graphics, Windows 10 Pro)

5
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Thomas Ward
    Aug 10 '18 at 20:19
  • Can you update your question with the exact Microsoft Surface Book model? Also can you add in the make and model of your Ethernet device? Aug 12 '18 at 18:42
  • @WinEunuuchs2Unix done Aug 14 '18 at 12:33
  • 1
    Could you solve your problem? I am at the exact same thing
    – Pmpr
    Nov 16 '18 at 13:22
  • @Trix nope... Gave up and removed the dual boot. Nov 16 '18 at 17:58
4

After trying various solutions, the only thing that worked eventually was resetting the router. Moral of the story: try the simplest solutions first.

3
  • So, I have dualboot, and after I boot windows, booting back to Ubuntu requires me to restart my router, I have no idea why, but thanks for this answer otherwise I would not think about doing this.
    – eri0o
    Jan 3 at 15:57
  • What do you mean by "reloading?" Do you mean resetting?
    – Dean P
    Jan 4 at 14:34
  • Precisely this. Jan 4 at 16:30
2

If a dual boot with Windows 10, you may need to disable the fast startup options first. See link...

I needed to do this to allow to connect to the internet. Do this first, then install Ubuntu.

Ubuntu Network Connection Issue

3
  • 1
    I already had that disabled, unfortunately, no luck. Thanks for sharing though! We have narrowed it down to issues with the surface dock firmware. I have since removed Ubuntu to a dedicated laptop. Dec 6 '18 at 18:04
  • Disabling "fast startup" required me to actually shut down the computer and wait for 30 seconds before the setting had any effect (just rebooting and installing Ubuntu did not work).
    – Reyhn
    Jan 20 '19 at 13:36
  • Confirmed that the computer had to be powered off after turning off "fast startup" in Windows, just rebooting would not work.
    – jasxun
    Nov 5 '20 at 6:48
1

Installing Ubuntu 18.04 LTS on an Acer laptop. I have restarted the system three times before eventually the Ethernet connection worked like a charm.

I am not suggesting that three is a magic number, but do not get discouraged after two attempts. I think to have been waiting long enough the first two times before concluding that no headway was being made. Among the attempts I disconnected and reconnected the wired connection manually from the menu, as though its master's voice had an effect as sometimes it has.

Nothing compares with the immediate response at the third try as expected. I could then download all the system updates. I cannot say yet whether these updates improve the situation for good. I might add a note later on. Hope this helps though.

0

A better way I have found is whenever there is change in network of the mobile hotspot, restart the hotspot and it will work again.

Sometimes you may need to change mobile to airplane mode and revert it work very well,

0

I had this problem with network-manager too and it helped simply to re-install it:

sudo apt-get install --reinstall network-manager

Then reboot your machine. It could help. If not, I would avoid dual-boot.
If this does not fix your problem then do the following...

sudo ifconfig [interface] down
sudo ifconfig [interface] up
1
  • 3
    Didn't worked. :( Thanks anyway. Aug 14 '18 at 23:24
-2

If you have installed Windows 10 and Ubuntu 20.04 in separate disk drives and they boot separately, then you can try going into Windows and resetting the network adapter there.

Not the answer you're looking for? Browse other questions tagged or ask your own question.