1

I'm using Kubuntu 18.04 and have the Nvidia 396 driver installed. It "feels" quite glitchy, and I'd like to try to the Nvidia 387 driver. I tried removing 396 using:

sudo apt remove --purge nvidia-*
sudo apt update
sudo apt autoremove

I then tried to install the Nvidia 387 drivers using:

sudo apt install nvidia-387

However, it just installed the Nvidia 390 drivers!?

Any idea how I can install the Nvidia 387 drivers?

  • 1
    There aren't any nvidia-387 packages in the default 18.04 repos. – karel Aug 4 '18 at 11:53
  • Ah, ok. So that explains why when I do sudo apt list | grep 387 I can see: nvidia-387/bionic,now 390.77-0ubuntu0~gpu18.04.1 amd64 [installed]. I'll try rolling back to 16.04, will see how that goes. By the why - I'll mark yours as an answer if you copy/paste it as an answer. – Scott Deagan Aug 4 '18 at 11:57
  • Not exactly sure what you mean by "non-reproducable" - it's easy to reproduce: 1. Install Kubuntu 18.04. 2. Try to install the Nvidia 387 drivers. – Scott Deagan Aug 4 '18 at 12:36
3

There aren't any nvidia-387 packages in the default 18.04 repos. The closest match to nvidia-387 in 18.04 can be installed as follows:

sudo ubuntu-drivers autoinstall # installs nvidia-driver-390   
sudo reboot   

When installing an Nvidia proprietary graphics driver, it is not necessary to uninstall the nouveau open source graphics driver. The two graphics drivers can be installed alongside each other allowing the open source graphics driver to be used as a fallback alternative in case there is a problem using the proprietary graphics driver.

The autoinstall command of ubuntu-drivers installs drivers that are appropriate for automatic installation including their dependencies.

There also isn't a package named nvidia-390 in the default Ubuntu 18.04 repositories as the results of apt show nvidia-390 shows:

$ apt show nvidia-390
Package: nvidia-390
State: not a real package (virtual)
N: Can't select candidate version from package nvidia-390 as it has no candidate
N: Can't select versions from package 'nvidia-390' as it is purely virtual
N: No packages found

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.