5

SETUP

  • Processor - Intel® Core™ i3-3220 CPU @ 3.30GHz × 4
  • Graphics - Intel® Ivybridge Desktop

Problem

I updated to Ubuntu 18.04, and I'm facing tremendous screen flickering/shaking/distorting at random times for random duration. The display is working fine on another Monitor that I have.

4

See if this works:

This method works only if you’re using Intel Graphics with an Intel SandyBridge (2nd generation) CPU or newer.

Create an empty file anywhere using right-click menu. Name it 20-intel.conf Open it using any text editor (like Gedit, Mousepad etc.) and add the following lines:-

Section "Device"

Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "sna"
Option "TearFree" "true"

EndSection

Now save the file. Open your file manager with root privilege (sudo -i nautilus for Ubuntu). Paste the file in /etc/X11/xorg.conf.d Create the requisite folders if they don’t exist. Restart the system after it’s done.

If you experience issues like pixelated graphics, corrupt text, etc. after this, replace the word sna with uxa within the text.

  • nothing changed after doing this. Will this problem get resolved if i use a graphic card instead – ĂŃĨĶĔŤ ŔĂĨ Aug 5 '18 at 11:13
  • Sorry to hear that! I also have a 3rd generation Intel i3 and this method works for screen tearing during video playback. I don't know if that'll solve the problem. – HattinGokbori87 Aug 5 '18 at 19:14
0

I was observing screen flickering but not shaking. I had to edit my monitor config and change the framerate. By default mine was set to 60.169086456298828.

open terminal and run the following:

gedit ~/.config/monitors.xml

edit this line:

<rate>60.1690864562988</rate>

set it to be lower than 60 as mentioned by 4levels, I used 59.96.

  • 1
    You do not need to use sudo when edit a file within your home directory ~... – pa4080 Aug 29 '18 at 6:58
  • Actually this helped to get rid of the flickering screen on my T570 with switchable graphics in Intel mode. The refresh rate is accessible as a drop-down option via system settings -> devices -> displays -> refresh rate. Thank you for pointing out the refresh rate as a possible solution! – byteborg Sep 1 '19 at 15:23
0

I faced the same problem when I updated my Ubuntu 16.04 to 18.04 LTS. The 18.04 is running by default on linux kernel v4.15 while new kernel version v5.0 and above are available. Try to change the kernel version using: https://kernel.ubuntu.com/~kernel-ppa/mainline/

Download packages according to your requirements, i.e., generic/low latency and install.

This solved my problem. Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.