3

I've just upgraded my Lenovo laptop from 16.04.LTS to 18.04 LTS and now can't get into Ubuntu (though dual loading with Win10 is OK).

When I get to the login screen, my user id appears, but if I then click on it I get a flash of the next screen (presumably where I'd enter my password) and Authentication Error appears and the system hangs - it shows the last block check data.

From the login screen (if I don't click on my name) I can use Ctrl and then log in and get to the command line. I've tried to do an update but it seems I don't have an internet connection (though it was working OK before the upgrade) so all of the answers I've looked at relating to similar questions won't work.

I asked the question initially on the Ubuntu Forums and only got one response which was to run sudo apt remove upstart --purge but which came with the warning that I ran it at my own risk! Again, it seems I might have a problem downloading any replacement packages.

Can somebody help me please?

Regards tomfilery

Added 5 Aug.

I tried the poster's suggestion but to no avail. From a bootable disk I can access the internet using an eternet connection, however, from the root of the installed version I can't. As far as I can tell only my bluetooth is off, wifi should be on but isn't working. If I try to run an update it can't access the ubuntu URL. I was going to reinstall Ubuntu (but don't want to lose exisiting info) but can't work out how to tell it which sda to use as boot, etc. - it just isn't intuitive Perhaps it's time to admit defeat and go back to Windows?

tom

  • Because you upgraded from 16.04 you should have previous kernel versions you can try out. Reboot and at the grub menu select "Advanced Options". Then pick an older kernel version to try. Keep us posted. – WinEunuuchs2Unix Aug 5 '18 at 19:01
  • Was anything encrypted on the 16.04 install - your user directory, or the whole disk? – Organic Marble Aug 5 '18 at 19:45
  • Organic Marble - no nothing was encrypted. – tomfilery Aug 6 '18 at 11:06
  • WinEunuuchs2Unix - I had hoped that would be the case, but it isn't. All of the 6 choices take me to the 18.04 login screen, where I come up against the initial problem. Have tried booting from USB and DVD, but can't access the web (even via ethernet - thought I could, but I can't). My data was backed up, but I need to check a few issues. Might have to do a complete reinstall - though am concerned that the original problem might still persist - a UEFI issue perhaps? Many thanks for your interest (and for Marbles too) - it seems in short supply at the moment. – tomfilery Aug 6 '18 at 13:47
0

I had ensured that I had backed up my Ubuntu system and data files prior to upgrading to 18.04 and, in the absence of any concrete help, after some research re loading data and settings back into various programs I decided that I could afford to reinstall Ubuntu from a live DVD using the option to reinstall Ubuntu overwriting existing data - so that is what I did. Slightly weird thing is it loaded Ubuntu on a 16GB partition and left all my existing data on a separate partition (400GB). So, at last it is up and running - now I just (he says) have to reload some apps and set them up.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.