0

Okay so I've already done some research on this and I seem to have an intersection of a few problems.

I have a drive /mnt/md0 that is a Raid1 3TB NTFS drive. My OS is 18.04.1 and is running off a separate SSD.

When I first right clicked on a folder in Nautilus it said "send to trash" and then when I did it would give me an error message saying it couldn't find the Trash folder. I did some research and found this answer: https://unix.stackexchange.com/questions/384237/cannot-delete-into-trash/384491#384491

So I followed these instructions to make a trash directory on my Archive drive.

 sudo mkdir -p /mnt/md0/.Trash-1000/{expunged,files,info}  

 sudo chown -R $USER /mnt/md0/.Trash-1000

This made a folder with the required sub folders etc.

Now when I right click it doesn't say "send to trash" it just says "delete permanently". I want to be able to send it to the trash. So I did more research and I found that the issue was that the folder did not have the proper permissions. I thought it did because I chowned it in the second command but when I locked at a folder inside I could see that only root has ownership and permission. I tried again, and it didn't work. So I tried via sudo nautilus and it would flick right back to root, as described in this issue someone else posted: Permissions fail to change, even using sudo nautilus

Apparently this has something to do with the filesystem being NTFS. I chmod 775 /mnt/md0 aaaaand.... it changed the permissions! Now everyone can write and delete files. BUT delete permanently is still the only option.

What should I do? I guess I could give everyone read, write, and execute privileges but that seems risky. This archive will hold a lot of important sentimental backups for photos and stuff and I'm mounting into a cloud server and I don't want to expose it to unnecessary risks. Any suggestions?

0

This issue ended up resolving itself once I rebooted the machine.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.