3

Whenever initramfs is updated I get a message similar to this:

I: The initramfs will attempt to resume from /dev/zram1
I: (UUID=1d4b8573-7eee-43c9-a02a-10a65fc17b8a)
I: Set the RESUME variable to override this.

However, because all my swap partitions are zram devices, I would like to disable resume. How can I do that?

4

You can disable resuming from swap devices by adding RESUME=none to the initramfs configuration.

Put this into a file named /etc/initramfs-tools/conf.d/noresume.conf:

# Disable resume (this system has no swap)
RESUME=none
  • Note that the value none is case-sensitive. Some other pages contain messages telling to use RESUME=NONE, which is incorrect. – Mikko Rantalainen Jan 11 at 17:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.