After having updated to Ubuntu 18.04, when I try to upgrade my system via
sudo apt update && sudo apt upgrade
I get this:
Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages have been kept back: gdb gir1.2-peas-1.0 libpeas-1.0-0 openshot 0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Of course I tried
sudo apt install -f without success:
$ sudo apt install -f Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
One suggested solution was to install each separately, but that doesn't work either:
$ sudo apt install libpeas-1.0-0 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libpeas-1.0-0 : Depends: libpython3.6 (>= 3.6.4~rc1) but it is not going to be installed E: Unable to correct problems, you have held broken packages.
So I tried to install libpython3.6, which doesn't work because
The following packages have unmet dependencies: libpython3.6 : Depends: libpython3.6-stdlib (= 3.6.5-3) but 3.6.5-5~16.04.york1 is to be installed
Now I can't remove/install/downgrade to this version because apt would then remove about 200 packages including things like xorg, firefox, gnome-session and pretty much every package I ever heard of.
One other thing I wanted to try taken from the question here was
sudo dpkg --install --force all /var/cache/apt/archives/libpython3[version].deb
but there was no file with my needed version number.
Edit: I downloaded the specific version via
apt download libpython3.6-stdlib=3.6.5-3 and installed it with above command. Now I can neither do upgrade nor autoremove, and I get this warning for both:
The following packages have unmet dependencies: libpython3.6-stdlib : Depends: libpython3.6-minimal (= 3.6.5-3) but 3.6.5-5~16.04.york1 is installed python3.6 : Depends: libpython3.6-stdlib (= 3.6.5-5~16.04.york1) but 3.6.5-3 is installed
What else can I do? Thanks for any help.