0

I couldn't find any info on how to solve my specific case, so here i am.
I've tried pretty much everything but hibernate doesn't work.
Edit: ignore this two paragraphs below, stuff has changed.

Running

systemctl hibernate

turns off my pc for a second, then it goes back on(no boot so it doesn't really turn off) and i see a blinking '_' for a second, then the pc completely shuts off. Manually powering back on results in a normal boot.

Running instead

pm-hibernate

turns off my mouse and screen, they then turn back on a couple seconds later.

Edit: the new situation
Running

systemctl hibernate

Shuts down the pc, however i only need to press a key to boot it up, after entering ubuntu in the grub menu this flashs on the screen, after the login nothing has been saved.

since before i have installed the uswsusp package, running

pm-hibernate

makes this appear on the screen before the pc shuts off, as before i only need to press a key to boot up, after the grub menu this appear before the login.

My guess is that the swap file is deleted at boot time(?).

Extra info:

  • kernel 4.15.0-29-generic
  • Ubuntu 18.04.1 LTS
  • swapfile of 16G(same as my RAM) Edit: expanded to 32G(no change)
  • pm-utils wasn't installed by default(dunno if it's helpful)

Adding code /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla doesn't make the hibernate button appear.

Thanks.

  • Hibernate means the contents of ram have to be written to disk, and at least in older versions it was written to swap (which means swap had to contain whatever was already in swap + all your ram; ie. swap had to be larger than ram by the amount of swap you were using at time of hibernate). My guess is your swap isn't large enough (unless you had nothing running, and no swap used) if a static-size; or had you disabled swap/played with swappiness? – guiverc Aug 2 '18 at 14:01
  • @guiverc i changed the swapfile to 32G, nothing different. – SteelRazor47 Aug 2 '18 at 15:44
  • The Ubuntu Podcast S11E20 (about 25mins in) talked about hibernate; and that its very hardware specific, and currently the kernel doesn't work with many systems (without a lot of hardware specific tweaking) which is why Canonical have it disabled for Ubuntu by default. Just a FYI. – guiverc Aug 3 '18 at 8:54
0

Try this way.

sudo apt-get install hibernate

After that just type in terminal

sudo hibernate

This way work for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.