1

On Ubuntu French forum, we made a link between the error message

PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e4(Receiver ID)

WIFI module and sky lake architecture. Not tested on kaby lake, no issues on haswell detected yet. The most common WIFI module linked to this issue is the rtl8723be (may be some others, not prooven)

I have seen this answer which is the most relevant for me, answered by C I king. Current workaround we apply is either pcie_aspm=off or pci=noaer parameter, which means either stopping the active state power management or stopping to report advanced errors.

Without one of these parameters, kern.log and syslog are flooded by this message. The rate has changed with the last updates (on 16.04) and on 18.04, we are talking about several GB in few 10 minutes. In addition to that, it appeared that on many computers (having sky lake architecture and rtl8723be module), live session cannot be started without one of these parameters.

We have tried several parameters set for the driver :

ips=0 fwlps=0 swlps=0 msi=0

ips=0 fwlps=0 swlps=0 msi=1

aspm=0

(sudo modprobe rtl8723be parameter_list)

We also tried the driver from github

No success to remove GRUB parameter. (Only to remove the WIFI driver).

Is there a known way (parameter or new driver) to avoid the GRUB parameter?

Thanks for the answer

1 Answer 1

0

I had the same problem. I could solve it only disabling ASPM - Active-State Power Management, a resource which helps PCI-E devices saves power.

sudo nano /etc/default/grub

Then, edit the variable GRUB_CMDLINE_LINUX_DEFAULT adding the parameter pcie_aspm=off, like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet pcie_aspm=off"

Save the file, and in terminal type

sudo update-grub
sudo reboot

If it still doesn't work try to create a file in /etc/modprobe.d/rtl8723be.conf with the following content. Then reboot again.

options rtl8723be ips=0 fwlps=0 aspm=0
1
  • Thanks for your feed-back pcie_aspm=off disable also AER (this can be check reading the CAP_EXP configuration). In all cases I faced, pci=noaer is enough
    – NicoApi73
    Oct 10, 2020 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.