I just created a brand new VM with Ubuntu server 18.04 and took the same steps I did earlier on another server (also a brand new 18.04 installation), but this time while attempting to install the mysql-server 8.0 it was suddenly failing.

The steps I followed were:

wget -c https://dev.mysql.com/get/mysql-apt-config_0.8.10-1_all.deb 
sudo dpkg -i mysql-apt-config_0.8.10-1_all.deb 

This configured my sources.list to use the 8.0 instead of the 5.x version of mysql.

Executing apt-get install mysql-server, I got:

mysql-server : Depends: mysql-community-server (= 8.0.12-1ubuntu18.04) but it is not going to be installed

Despite having run commands such as apt-get clean, apt-get install -f and apt-get update several times, and apt-get upgrade not reporting any held packages, I found this odd. So I tried apt install mysql-community-server.

Which resulted in the same error, but with missing depends for mysql-community-server-core and libmecab2.

When running apt install libmecab2 it tells me it has no installation candidate, but according to the ubuntu packages website it definitely exists in the repository.

I couldn't see anything out of the ordinary in my sources.list either, and apt-get update isn't reporting any errors either.

What could be causing this installation to fail? I took the exact same steps on the physical server, and it worked perfectly on that machine.

  • 1
    Your packages link tells you that libmecab2 is in 'universe', so do you have 'universe' repository enabled? (packages.ubuntu.com/bionic/libmecab2) – guiverc Aug 2 '18 at 10:54
  • That seems to have fixed it, weird that two installations end up with different configurations – xorinzor Aug 2 '18 at 10:56
  • I suspect you enabled universe on one, but thought it was so obvious you didn't push the idea into your long-term-memory so it never occurred to you for the second one... (pure guess though) – guiverc Aug 2 '18 at 10:59
  • nope, I literally did it 2 days ago haha, I just installed the OS and googled for how to install the 8.0 version. (even had to google just now how to enable the universe repo) – xorinzor Aug 2 '18 at 11:01
  • 2
    @karel I had no idea this was related to the universe repo when I asked the question. If someone has the same or similar issue and would google it, he/she wouldn't ever find that question/answer either as it's not similar at all. As such, I find it fair to say it's not a duplicate. – xorinzor Sep 24 '18 at 18:06

This package(https://packages.ubuntu.com/bionic/libmecab2 ) is in universe repository

Add deb http://archive.ubuntu.com/ubuntu bionic universe to your sources.list and run apt update to resolve it

or type these command in a terminal

sudo add-apt-repository universe 
sudo apt update
sudo apt install libmecab2
| improve this answer | |
  • I find it difficult to mark this as the answer, since @guiverc has been the person who answered the question already in the comments. – xorinzor Sep 24 '18 at 18:07
  • @xorinzor Comments section is not the right place to provide actual solutions as comments can get deleted easily for various reasons. Answers should always be posted in the Answers section. So consider "accepting" it to indicate you've found a working solution and also so that others may more easily find it in the future. Given @ guiverc is an experienced user here, I'm pretty sure they won't mind at all :-) – pomsky Sep 25 '18 at 4:44
  • @pomsky I suppose. It just doesn't feel right ;) – xorinzor Sep 28 '18 at 11:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.