1

i am running kubuntu 18.04 in virtualbox and currently working in a proxy environment. when i am trying to setup the proxy through
system settings ->network settings -> proxy .

then i see no changes and unable to browse. no system wide changes are observed ,ie proxy on system environment is not afftected after this . but as i am running
export_proxy http_proxy=http://'proxy:port'

env variable is changes and able to use the internet connectivity.

please provide solution for this , to setup proxy system wide through setting ,not by export_proxy ( i don't want to unset the proxy each time as i shift to non-proxy environment.)

  • Are you using Firefox ? It has its own proxy settings and ignore system-wide settings (as of writing). – John Christopher Mar 5 '19 at 11:00
  • @JohnChristopher yes I was using Firefox, but this issue also exists for chrome – sahasrara62 Mar 5 '19 at 14:37
1

can you precise the string format you use to setup proxy system wide trough system settings -> network settings -> proxy

http://proxy_host:port or proxy_host:port

i open a bug against firefox and ask a similar question to ubuntu:

i suppose (it works for me) if you type http://proxy_host:port it works for firefox (but not for evolution or pidgin)

IMHO it's wrong to say : FF has its own proxy settings and ignore system-wide settings and in my case : chrome uses proxy settings and i can browse with both values : http://proxy_host:port or proxy_host:port

| improve this answer | |
  • thanks for solution, right now i have no access to the system to check this one, but yes your solution is right and one can set the proxy this way also. – sahasrara62 Sep 26 '19 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.