0

I just bought a new laptop which comes with Windows 10 on a 256gb SSD. There is no other disk storage.

The Windows 10 install has to stay because it's for my wife to use. I then used a Kubuntu (18.04) USB installer to install Kubuntu. During install, it asked if I wanted to install proprietary graphics drivers, and that doing so I would have to disable Secure Boot. I didn't really think about that at the time and just checked the boxes and set up the password (big mistake). I then assigned Kubuntu roughly half the existing drive (so Windows was shrunk to ~140gb with ~110 for Kubuntu).

Now, when the computer boots, it boots straight to Windows 10 (instead of giving us the option of either). In order to access the Kubuntu partition, I have to boot Windows 10, then access the Secure Boot menu from within Windows and restart treating the Kubuntu partition like booting from an external device. To fix this, I went to re-install Kubuntu over the existing Legacy installation, but the Kubuntu installer doesn't recognize the Legacy installation (probably because the bootable USB is being booted from UEFI). Is there any way to fix this without reformatting the entire drive (including Windows 10)?

1
  • 5
    If you booted in UEFI mode, then you installed in UEFI mode whether Secure boot is on or off. Only if you booted in BIOS mode would it install in BIOS mode.But Secure Boot requries signed grub & kernels and you cannot use any proprietary drivers which may be needed to work well. What brand/model system? If Windows still works and drive is then gpt, you can just reinstall the UEFI version of grub. Use Boot-Repair's avanced options from live installer in UEFI mode. help.ubuntu.com/community/Boot-Repair
    – oldfred
    Aug 1, 2018 at 22:21

1 Answer 1

0

Okay I had the same when I installed the Ubuntu 18.04. The Grub menu was not showing up and then I understood it had something to do with the UEFI. With the latest UEFI Firmware most of the manufacturers(or all not sure) have the secure boot to on. You just have to visit your UEFI by logging in to Windows or provide the key combinations before Windows boots up based on your manufacturer(might be f10 I guess). In case you login to Windows navigate to

Settings-> Update&Security-> Recovery-> Restart now(Under Advanced Startup) (OR)

Hold down Shift key while doing the restart.

Blue screen with menu must appear now. Navigate to Troubleshoot & then advanced options and UEFI Firmware Settings and press restart.

Select F10 (Bios Setup) go to System Configuration-> Boot Options set secure boot to off. This should work. In case if it doesn't then change the UEFI boot order(OS Boot Manager) to Ubuntu by changing the values by f5 or f6(save settings and exit).

Please note: Instructions provided match for the HP Notebooks (might be different set of keys for other manufacturers).

Your Grub must appear now. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.