3

I followed the answer here: How do I kill redshift?. I ran this command

redshift -o 6500

I receive the following error message:

Trying location provider `geoclue2'...
Using provider `geoclue2'.
Unable to start GeoClue client:
GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Geolocation 
disabled for UID 1000. Unable to connect to GeoClue. 
Unable to get location from provider.

How to set it so it has access to my geolocation and sets the brightness?

  • 1
    That command you are typing in should be redshift -O 6500. You can try to set it manually: askubuntu.com/a/951469/231142 I have included the link to find your lat and long that you can put in your ~/.config/redshift.conf file. – Terrance Aug 1 '18 at 13:42
4

The quick workaround is use capital -O (One shot manual mode) instead of small one -o (One shot mode) i.e:

redshift -O 6500

GeoClue is the Geolocation service which needs the location service enabled. So make sure that Location service is enabled from Settings > Privacy:

enter image description here

I was getting the same error, after creating configuration file (~/.config/redshift.conf) as explained at official site and now redshift and redshift-gtk is working fine:

; Global settings for redshift
[redshift]
; Set the day and night screen temperatures
temp-day=5700
temp-night=3500

; Enable/Disable a smooth transition between day and night
; 0 will cause a direct change from day to night screen temperature.
; 1 will gradually increase or decrease the screen temperature.
transition=1

; Set the screen brightness. Default is 1.0.
;brightness=0.9
; It is also possible to use different settings for day and night
; since version 1.8.
;brightness-day=0.7
;brightness-night=0.4
; Set the screen gamma (for all colors, or each color channel
; individually)
gamma=0.8
;gamma=0.8:0.7:0.8
; This can also be set individually for day and night since
; version 1.10.
;gamma-day=0.8:0.7:0.8
;gamma-night=0.6

; Set the location-provider: 'geoclue', 'geoclue2', 'manual'
; type 'redshift -l list' to see possible values.
; The location provider settings are in a different section.
location-provider=manual

; Set the adjustment-method: 'randr', 'vidmode'
; type 'redshift -m list' to see all possible values.
; 'randr' is the preferred method, 'vidmode' is an older API.
; but works in some cases when 'randr' does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

; Configuration of the location-provider:
; type 'redshift -l PROVIDER:help' to see the settings.
; ex: 'redshift -l manual:help'
; Keep in mind that longitudes west of Greenwich (e.g. the Americas)
; are negative numbers.
[manual]
lat=48.1
lon=11.6

; Configuration of the adjustment-method
; type 'redshift -m METHOD:help' to see the settings.
; ex: 'redshift -m randr:help'
; In this example, randr is configured to adjust screen 1.
; Note that the numbering starts from 0, so this is actually the
; second screen. If this option is not specified, Redshift will try
; to adjust _all_ screens.
[randr]
screen=0

You can fed latitude and longitude of your location manually @ 45th (lat=) and 46th (lon=) line for above mentioned configuration file. Note that I needed to change screen=1 to screen=0 in the last line.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.