0

Every time I leave the XPS13 for about 30-60 minutes, the Bluetooth symbol disappears and the mouse stops working.

I have already tried to install this drivers: https://www.killernetworking.com/driver-downloads/kb/faq/1-killer-1535-1525-1435-in-ubuntu-debian

Also installed this one: https://www.dell.com/support/home/us/en/04/drivers/driversdetails?driverId=1JVK3 where I have overwritten these files:

AthrBT_0x00000302.dfu (size 40876) -> rampatch_usb_00000302.bin (size 32940)
ramps_0x00000302_48.dfu (size 1982) -> nvm_usb_00000302.bin (size 1953)

Also tried to restart bluetooth: sudo service bluetooth restart

But its not working until computer restart! Is there a solution for this?

0

This is a known problem, lots of info at this question. AT least your XPS appears to sleep...mine doesn't, it just suspends, hoping both will get fixed!Edit:you will need to read the comments...

  • That said, restarting bluetooth using the very same command as you mention works for me when mine gets disabled, in fact I have it in an easy-to-type-name script. – B.Tanner Aug 1 '18 at 14:42
  • Unfortunately your link contains no useful info in terms of bluetooth – saitam Aug 1 '18 at 16:02
  • It does if you look closely enough in the comments like I said! Look for for a heading of "Permanent Fix" in one of the answers and then the following comments. – B.Tanner Aug 1 '18 at 19:47
0

For me the solution was to install the new Kernel, even tough I have updated to 18.04., the Kernel was still 4.15.0.30.32, so I updated to 4.17.13 and now everything works fine.

Unfortunately I don't know whether the solution was on to install the new Kernel or a combination of using the driver mentioned above and a few other things I have tried meanwhile.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.