8

I just did a clean installation of Ubuntu 18.04.1 on a tablet which was previously running Ubuntu 17.10. Back then just after the installation the screen was rotated, but I was able to get it to work (I think it was running on Wayland).

Now with 18.04.1 the situation is similar: when Ubuntu first boots the login screen is upside-down, but that's not a problem. This time, after login, the screen is correctly oriented but the mouse cursor is upside down and mouse movements are inverted with respect to both axes. The problem is that when I try to click on something the click is registered on the position on the other side of the screen (symmetrically with respect to the center).

It almost seems like the screen (desktop, application, etc.) is correctly displayed, with also the mouse positioned correctly and moving as it should, but then the mouse cursor which is shown to the user is inverted, like if the screen had been inverted just before drawing the cursor.

I already tried the answers I could find, but none worked for me. Anyone have an idea of what's going on?

Thanks

10

I tried following these instructions, but that didn't work. Then what I did was simply open Terminal using Ctrl+Alt+T and invert the screen using

xrandr --output eDP-1 --rotated inverted

Then running

sudo apt-get update
sudo apt-get upgrade

After rebooting, everything went back to normal.

To prevent GNOME from communicating with the sensor hardware I ran the command

sudo apt-get remove iio-sensor-proxy

This solved everything for me.

4
  • 2
    I didn't need to do the xrandr command. I just ran sudo apt remove iio-sensor-proxy, then sudo apt update, sudo apt upgrade, and sudo reboot – HackerBoss Jan 28 '19 at 16:11
  • I had the same problem on Ubuntu 20.04 on a Pixelbook 2017 ("Eve"/Kabylake). sudo apt-get remove iio-sensor-proxy and a reboot didn't help, and (initially) neither did the call to xrandr. It turned out that the solution was similar but slightly different: xrandr --output -eDP-1 --rotate normal (so "rotate" instead of "rotated", and "normal" instead of "inverted") – Kreuzfeld May 21 '20 at 1:42
  • ... And after another reboot, it turns out I have to set the above line to execute after every startup, otherwise the entire screen in inverted again. – Kreuzfeld May 21 '20 at 2:06
  • @Kreuzfeld once you rotate it to normal then you can simply disable the sensor by removing the iio-sensor-proxy package as I highlighted. – khalid May 21 '20 at 7:11
5

You can just run

sudo apt remove iio-sensor-proxy

and reboot then. Everything would come back to normal.

1

In my case, the screen and the cursor went upside down after Upgrading to the new 19.04 version.

I just ran the command :

sudo apt remove iio-sensor-proxy

Then I reboot and everything is back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.