6

I tried to update using the update manager and I couldn't because I encountered an error halfway through (error: brokencount>0). I have tried apt-get -f install, but it doesn't work.

You can check my terminal:

trungtin@trungtin-S551LN:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree   
Reading state information... Done
The following packages were automatically installed and are no longer required:
debugedit libllvm5.0 librpmbuild3 librpmsign3 rpm swarm
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
ethereum-swarm
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
1 not fully installed or removed.
Need to get 0 B/5.560 kB of archives.
After this operation, 22,2 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package ethereum-swarm.
(Reading database ... 316020 files and directories currently installed.)
Preparing to unpack .../ethereum-swarm_0.3.1+build14601+xenial_amd64.deb ...
Unpacking ethereum-swarm (0.3.1+build14601+xenial) ...
dpkg: error processing archive /var/cache/apt/archives/ethereum-swarm_0.3.1+build14601+xenial_amd64.deb (--unpack):
trying to overwrite '/usr/bin/swarm', which is also in package swarm 2.1.6-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/ethereum-swarm_0.3.1+build14601+xenial_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have tried to clean cache then install again or overwrite ethreum-swarm.

5

I removed the ethereum ppa with sudo add-apt-repository --remove ppa:ethereum/ethereum and then had to run sudo apt-get -f install as the error message suggested, before any other apt commands would complete. Then I could run sudo apt-get purge swarm successfully, and then I could run sudo apt upgrade. I couldn't comment on what things are necessary or sufficient, though.

  • yup, worked likea charm. I gave up on solidity all together with Ether, a security mess atm, will revisit in the future. Thanks Alex. – clusterBuddy Aug 3 '18 at 16:42
  • This worked after the update process broke, thank you. – Mark Carpenter Jr Aug 4 '18 at 18:08
4

Three options here:

  • ask package authors about conflict between their ethereum-swarm and ubuntu package swarm.

  • remove standart swarm Ubuntu package and then install ethereum-swarm:

    sudo apt-get purge swarm
    sudo apt-get install ethereum-swarm
    
  • force installation of ethereum-swarm (you take this risk, as this is not recommended):

    sudo dpkg -i --force-all \
    /var/cache/apt/archives/ethereum-swarm_0.3.1+build14601+xenial_amd64.deb
    

    then remove swarm package with sudo apt-get purge swarm and reinstall sudo apt-get install --reinstall ethereum-swarm again (to keep system clean).

  • How can I use sudo apt-get purge swarn? – Tín Huỳnh Aug 1 '18 at 10:55
  • @TínHuỳnh In current state it may not work, but you can try. Then use third method (with --force-all). – N0rbert Aug 1 '18 at 10:58
  • But it takes risk right? – Tín Huỳnh Aug 1 '18 at 11:00
  • Usually such method is not recommended. But in current situation it is normal. – N0rbert Aug 1 '18 at 11:02
  • When I run sudo apt-get purge swarm it still gives me the same error; The following packages have unmet dependencies: ethereum : Depends: ethereum-swarm but it is not going to be installed How can I uninstall swarm? – Alex Altair Aug 2 '18 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.