0

I am not able to shut down or restart by clicking power off or restart button. I need to manually press the power key on my laptop to force shut down every time.

The desktop screen simply freezes and mouse disappears, and if I leave it for some time then a black screen appears with this:

watchdog: BUG. CPU stuck for 22 sec. Tlp 5770.

And this doesn't go away.

I have tried everything I could find like

acpi = force , etc. Installing Nvidia drivers. Changing CPU governor to performance from powersaver.

I am new to Linux and really don't know what to do. I have Lenovo legion y520 with 16 gb, 1 TB, Nvidia GeForce 1050 Ti as the configurations. I removed Windows 10 and installed Ubuntu 18.04.

Please help!

  • you can use as a temporarly solution the command line shutdown -f 0 in your terminal (the computer will shutdown itself when you will press Enter) – damadam Aug 1 '18 at 9:15
  • Thank you for replying! No, that didn't work. When I pressed enter, the same thing happened! The desktop screen stayed on and mouse disappeared and system hanged. I had to force shutdown again. :( – Costa Aug 1 '18 at 11:49
  • so that's not a problem of the desktop – damadam Aug 1 '18 at 12:03
  • is it a fresh install of Ubuntu? Do you have edited some config/system files? – damadam Aug 1 '18 at 12:05
  • Yes, I installed it a few days ago. No, except from 'acpi' thingy, I haven't touched any other system files. It has been like this from the start. I even tried lightdm today instead of gdm3 but that too hanged my computer when I tried to shut down, so I switched back. Another thing, I am able to turn on or off the keyboard lights, that's there. But the screen hangs as well as the power indicator light stays on. – Costa Aug 1 '18 at 12:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.