Ubuntu 18.04.01 upgraded from 16.04

Shift Alt Down does not work in PHPStorm. Also, I can't assign any shortcut to it and it is not recognized as a shortcut (but top, left, and right do get recognized.

I use PHPStorm and cannot do a Move Line Down because of this.

cat /etc/default/keyboard
XKBLAYOUT=us
XKBVARIANT=intl
BACKSPACE=guess

enter image description here

EDI: I have reinstalled the OS (18.04.1) just to ensure it wasn't a problem with updating. BUT I kept my home folder. It doesn't work either. But my Gnome extensions are there, so maybe there is a config directory for it in my home folder? Previous to reinstall, I renamed the folders gconf, gnome and compiz in the home folder.

  • Can you please edit your question and show us the output of the command cat /etc/default/keyboard – Gunnar Hjalmarsson Aug 10 at 23:59
  • @GunnarHjalmarsson done – JorgeeFG Aug 11 at 0:07
  • Ok, the explanation is not there. What about the output from this command: gsettings get org.gnome.desktop.input-sources xkb-options – Gunnar Hjalmarsson Aug 11 at 0:15
  • @GunnarHjalmarsson @as [] – JorgeeFG Aug 11 at 0:48
  • Thanks. My theory was that Alt+Shift had been silently enabled as a shortcut for changing input language, and thus prevented the shortcuts you mention to work properly. Now we know that's not the case. So we are back at square one. Hopefully someone else is able to help. – Gunnar Hjalmarsson Aug 11 at 0:57

Try a basic keyboard configuration. In my 16.04 and 18.04 it is setup like this:

$ cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

There is a bug report: Unable to use shortcuts with keyboard layout switcher on Ubuntu MATE, 16.04 (with HWE), 17.10 and 18.04 LTS

Unfortunately the bug report has no fix yet.


Fortunately there is a solution that might work posted by Norbert in another forum: Keyboard layout switching problems and poll:

sudo add-apt-repository ppa:nrbrtx/xorg-hotkeys
sudo apt-get update
sudo apt-get dist-upgrade

Please read both links thoroughly before proceeding.

  • Hi, it didn't fix my poblem. I do NOT have a problem switching keyboards, my problem is just that I cannot assign ALT SHIFT ARROWDOWN as a shortcut. (And while it is set as a shortcut in PHPStorm, from previous setup, it does not work). In Ubuntu Settings, Devices, Keyboard, Add new shortcut, ALT SHIFT ARROWDOWN does not get recognized. But ALT SHIFT ARROWUP for example, does. – JorgeeFG Aug 13 at 0:26
  • @JorgeeFG Sorry to hear that. I've added one more thing to try at the top of the answer. If that doesn't help I'll delete my answer. Thanks. – WinEunuuchs2Unix Aug 13 at 0:33
  • Do you have 18.04? Can you assign the shortcut I named? Because if you can, maybe it is some config remaining in my home directory. Although I could try with a new user I guess – JorgeeFG Aug 13 at 1:44
  • Indeed it does work, same as Super L to lock. What should I delete in my home directory? – JorgeeFG Aug 13 at 1:52
  • @JorgeeFG Keyboard shortcuts are not stored in one place: askubuntu.com/questions/26056/… – WinEunuuchs2Unix Aug 13 at 1:57
up vote 0 down vote accepted

I certainly don't know the exact answer of why this happened or what is the related config.

I saw that with a new user, this problem and the Super L to lock not working, were solved.

So I tried copying the .config directory of the new user, but it didn't work. Then I copied all the files and directories beginning with a dot (hidden) including the .profiles and it worked. I lost all the configs, but it is worth.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.