so I've been asking about display and graphic drivers in the past and I still couldn't solve the problem on my Lenovo laptop. I'm using Ubuntu 18.04 on a laptop with Intel/AMD hybrid graphic. After running lshw -c video I get this:

 sudo lshw -c video
       description: VGA compatible controller
       product: HD Graphics 5500
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:49 memory:d0000000-d0ffffff memory:c0000000-cfffffff ioport:5000(size=64) memory:c0000-dffff
       description: Display controller
       product: Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 83
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: irq:50 memory:b0000000-bfffffff memory:d1000000-d103ffff ioport:3000(size=256) memory:d1040000-d105ffff

I had radeon driver installed, but today I put amdgpu because i thought it would be enough. The exact problem can be see on the following picture: enter image description here

As you can see the dark parts are blurry/pixelated. This is the case when I play videos, or even if I want to set a darker background image. Next image.

It seems that even if I have an AMD graphic driver, my laptop is using the Intel one: enter image description here

So my question is, is it possible to change between the two graphic drivers somehow? As a newbie to this stuff I really don't have other ideas, what could cause the blurry screen. I had an older Fujitsu laptop like 6 years ago with intel graphics and Ubuntu worked perfectly on it then. Any help would be appreciated. Thanks.

2 Answers 2


Your graphics card is GCN 1st generation (see this overview), for which amdgpu support is experimental and radeon is the recommended driver.

If you do want to use the amdgpu driver for your card, you need to explicitly enable it. To do so, edit /etc/default/grub and add amdgpu.si_support=1 radeon.si_support=0 or amdgpu.si_support=1 modprobe.blacklist=radeon to GRUB_CMDLINE_LINUX.

However, you are probably better off using the radeon driver. For instance, you'll see your laptop battery drain much quicker as the amdgpu will currently not power off the card when the Intel is in use.

To use the radeon, either set radeon.si_support=1 amdgpu.si_support=0, or blacklist the amdgpu, or do nothing, as the radeon driver is the default for your card.

After editing /etc/default/grub remember to sudo update-grub.

  • Thank you. do you think that setting radeon in grub and blacklisting intel will help? The biggest problem is the condition of the display as you can see on the pictures above. I have no idea what causes the blurry parts, that's why I was thinking about switching to radeon/amdgpu.
    – user322376
    Aug 1, 2018 at 4:21

Regarding the "blurry" areas... The pixelation in the dark areas of your first picture are normal. That's the video streaming service highly compressing the dark areas because they assume you won't notice. If you can force a higher resolution, thay might help.

The second photo also looks normal. It's a highly compressed image.

You must log in to answer this question.