0

I have received a MSI GS65 8RE-052FR Stealth Thin laptop that comes with Windows 10 enterprise pre-installed (I was previously working with Windows 7). I am trying to install a dual-boot with Xubuntu 18.04.

I have already partitioned the hard drive to make some space for Xubuntu. Next step is trying Xubuntu from a Live USB.

I have a USB drive for this with Multisystem and a collection of Linux variants. I have tested the USB drives on another laptop (a DELL with also Windows 10). I can boot the latest version of Xubuntu (18.04) from the USB drive through both Legacy BIOS or UEFI on this laptop.

Note for those who own the same laptop and search how to access the boot media menu at startup : on this computer, it's with F11, not F12 or F2. Similarly, to access the UEFI menu at computer startup, press DEL.

I have gone through several problems with the MSI laptop. First of them : to find how the hell you access the UEFI menu from the bloody Windows 10 interface ! (Finally found it : restart while pressing down Shift to access some menu which I am not even sure if it's part of Windows or UEFI).

Then I tried disabling the UEFI to switch to Legacy BIOS and disable Fast Boot. It simply ended up messing everything completely : I could not start neither Windows, nor from a Live USB, nor access again UEFI (I need to boot Windows first !). Fortunately, I could reset UEFI by pressing down the power button for 20 seconds.

I have learned in the meantime that the latest versions of Ubuntu can boot from UEFI so decided I would give it a try since Legacy BIOS had not worked. I have accessed again UEFI and checked : Secure Boot is not active ; I have disabled Fast Boot ; the boot mode is UEFI.

Results : - I can still boot Windows (good). - I can still choose the boot media at startup (good). - Then I can choose Xubuntu 18.04but it ends up being completely stuck during the OS boot. - But if I choose Xubuntu 16.04, it works !

What the hell ! I can only boot / install older versions of Ubuntu ?!

Here is the result of Boot-Info : https://pastebin.com/gG0d2mCV but I don't believe it has anything to do with it.

I have also tried this with Linux Mint with the same result.

  • If Windows is UEFI boot on gpt partitioned drive, you do not want anything to do with the 35 year old BIOS/Legacy/CSM. CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode is only offered to allow boot of old systems. Have you updated UEFI from MSI. Generally better to boot Ubuntu live installer and add Boot-Repair to it with ppa, to get newest version. MSI GE63 Update UEFI then acpi=off not required askubuntu.com/questions/1059029/18-04lts-msi-ge63-boot-issues & askubuntu.com/questions/1038637/… – oldfred Jul 31 '18 at 15:36
  • Hello. I followed the links and did what people had done for their MSI GS63 : updated the BIOS to the latest version (and disabling again Window's fast boot and the BIOS Secure Boot) but it did not change anything. – Darth Kangooroo Aug 1 '18 at 10:14
  • But adding acpi=off to the GRUB menu works ! I can boot the Live CD. The problem will be now : how do I install it ? – Darth Kangooroo Aug 1 '18 at 10:47
  • Shows install with screen shots. Both BIOS purple accessibility screen & UEFI black grub menu screen help.ubuntu.com/community/UEFI Also shows Windows 10 screens or similar to Windows 8 askubuntu.com/questions/221835/… & askubuntu.com/questions/221835/… – oldfred Aug 1 '18 at 14:50
  • I have been suggested that the problem could be the lack of support of the laptop's processor by the kernel. – Darth Kangooroo Aug 2 '18 at 8:19
0

Ok. I found the answer with the help of the French Ubuntu Forum :

  • so disable Fast Boot and Secure Boot.
  • resize partition in Windows to make space for Ubuntu.
  • boot from Live USB after editing the GRUB. I tried the following :

    • with acpi=off : boots with low-resolution display (800x600)
    • with nomodeset : same thing.
    • with modprobe.blacklist=nouveau , boots with a correct display ! (1920x1080)

So from a Live USB session (with modprobe.blacklist=nouveau ), I installed Ubuntu (actually LM). At computer reboot, it started Windows with giving the choice between Windows and Ubuntu. I had to enter the BIOS and change the boot order to have "USB: Hard Disk" before "Hard Disk: Windows Boot Loader". Then at restart, I had the GRUB offering the choice between Ubuntu and Windows but still ought to edit the GRUB to add modprobe.blacklist=nouveau. Then from the Ubuntu session, I used the Driver Manager to activate the nVidia driver and now I can boot without editing the GRUB. At last !

Only small issues left : clock difference between Ubuntu and Windows and for some reason, the Ubuntu install did not create a swap.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.