2

The card itself doesn't seem damaged. I can read files and store them without troubles or errors. However, if I unmount and then mount it again all changes disappeared. I want to format it but the following doesn't work and the strange thing is that I receive no error. Note that I use the sd card through an adapter.

sudo umount /dev/mmcblk0p1
sudo mkfs.vfat -F32 -v /dev/mmcblk0p1 

This is the output of the last command.

mkfs.fat 4.1 (2017-01-24)
/dev/mmcblk0p1 has 4 heads and 16 sectors per track,
hidden sectors 0x2000;
logical sector size is 512,
using 0xf8 media descriptor, with 62543872 sectors;
drive number 0x80;
filesystem has 2 32-bit FATs and 32 sectors per cluster.
FAT size is 15264 sectors, and provides 1953541 clusters.
There are 32 reserved sectors.
Volume ID is 58e20b82, no volume label.

However, when I remount the sd nothing changed. I also tried with gparted but return an error and do nothing at all.

  • Every micro SD adapter has a slidable button on their side that will report the micro SD card inside them as read-only. Have you tried flipping this button? – HattinGokbori87 Jul 31 '18 at 11:39
  • @HattinGokbori87 Yep. I also tried flipping the button just to be sure. Nothing change at all. I mean that it seems read-only independently of the state of the button. – gvgramazio Jul 31 '18 at 11:43
  • @HattinGokbori87 I also tried this answer but with no result and no error message. Also, independently of the switch, the permission are rw-rw----. – gvgramazio Jul 31 '18 at 11:49
  • Sorry to hear your problem isn't solved. Just a a non-developer Ubuntu user so my plan stopped at the side button:-) Hoping someone can soon give you some answers. – HattinGokbori87 Jul 31 '18 at 19:25
0

if your SD card is unable to format, it means the file allocation table is corrupt or missing. And it will always shown as RAW, unknown or unsupported. In this case, you can try the below method.

  1. Try other device or system The unable to format issue may rooted with the card itself or the device interacting with it. So,just try to insert the SD cards to other device or other system to see if this solves the issue.

  2. Rename the card You card may works well on mobile devices but PC. Then, the instant way is to rename the card. Here's how to rename your SD card.

  3. Use CHKDSK Command If the above two method fails, your SD card might logically damaged due to file system corruption. Then, CHKDSK should be your first choice to recover formatted data. You can follow the steps here to do it.

  • In all these cases, shouldn't I able to correctly see the files inside? Because right now I'm able to see them. – gvgramazio Aug 3 '18 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.