0

I have Ubuntu 18.04. I cannot change my keyboard language. When I try with shortcut, nothing going on. When I try with clicking on the language and change it, the icon of the language changes, but when I writing the language is still English. I have only 2 languages - Bulgarian and English. I cannot switch to Bulgarian. Before 2-3 weeks everything worked fine, but now when turn on my laptop it doesn't work. I don't know what caused this. If you have some questions do not hesitate to ask.

Edit: Actually I notice that even shortcuts for opening terminal does not work, so maybe there is some global problem with the shortcuts.

Thanks in advance.

  • What is your desktop environment? What is keyboard layout switching shortcut? Where did you set it? How many keyboard layouts do you have? – N0rbert Jul 31 '18 at 9:51
  • Hi, N0rbert, My laptop configuration is: most.bg/e9y44ea-450-i7-4702mq-15-6-8gb.html My shortcut switching keyboard shortcut is: ALT + SHIFT I have 2 layouts - BUlgarian and English US Actually, I understand that I have general problems with some shortcuts. I edit my question. – DPM Aug 1 '18 at 18:43
  • If you use GNOME, you need to use GNOME Tweaks to set <Alt+Shift>. See this answer. – N0rbert Aug 2 '18 at 8:20
1

I had the same problem. The following steps fixed the issue for me:

  • Go to Settings -> Region & Language
  • Temporarily remove all other keyboard layouts, just leave Bulgarian.
  • Try writing something - now you should see Bulgarian characters
  • Finally, re-add the other keyboard layouts (English US in my case) and reorder them to suit your liking.
  • Hi, rapture, Thanks for your attention. Unfortunately, this does not work for me :( Actually, I understand that I have general problems with some shortcuts. I edit my question. – DPM Aug 1 '18 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.