30

I am trying to type in Arabic as well as in English. I set up the Arabic keyboard using the following steps:

Settings -> Region & Language -> + -> Arabic

I also added Arabic (QWERTY) just to check.

After doing that I get the little switcher on the top right. The problem is when I switch the language it keeps typing in English. Anyone know what is going on? I am very confused!

2
  • Restarting magically worked. Still a bug though!
    – Zatara7
    Jul 31 '18 at 18:22
  • 1
    In my case, it didn't work even after restarting. the language icon is there but still types in English. Anyone solved it?
    – libphy
    Mar 19 '19 at 0:40
47

It is probably a bug from GNOME, I don't know, but restarting GNOME works. (You won't lose your open apps or the arrangement in virtual desktops.)

Press Alt+F2 and then write r and then press Enter.

8
  • 1
    works perfectly, شكرا, but what the r command means Jan 7 '20 at 13:46
  • @BasheerAL-MOMANI I guess it is r for restart
    – JorgeeFG
    Jan 7 '20 at 15:06
  • @JorgeeFG I did restart ubuntu but didn't work. restarting GNOME as you mentioned worked like a charm!
    – Kassem
    Feb 27 '20 at 1:15
  • @BasheerAL-MOMANI It will force write changes.
    – M. Rostami
    Mar 1 '20 at 16:06
  • I'm doing this on every boot. Is there a more permanent solution?
    – Arkanoid
    Jul 27 '20 at 13:40
7

you should restart I had the same exact problem and after a restart, it worked

1
  • nice, had the same exact issue, didn't knew from where the problem was, restarted and it got solved :D thanks!
    – Eek
    Oct 18 '18 at 7:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.