1

I am running Ubuntu 18.04 on my Asus ROG GL752VW, and I want my sleep button to hibernate my computer. This computer has always been difficult for Ubuntu and Fedora.

First, I enabled hibernate and tested it through sudo pm-hibernate. It worked.

Then, I attempted to make the sleep button Fn-F1 hibernate the computer. To accomplish this, I went in to dconf-settings and went to org.gnome.settings-daemon.plugins.power and changed the settings for both the suspend and the sleep button to hibernate. When I saved the settings then restarted the computer (which I do not think was necessary, but I did just to be safe), I double-checked that the setting was still hibernate using gsettings get org.gnome.settings-daemon.plugins.power button-suspend and the equivalent for sleep. After confirming, I pressed the sleep button. The computer suspended instead of hibernating. I then changed the value to nothing and restarted, and the button still suspended the computer.

This is a fresh install of Ubuntu. I am currently using the following boot options, some of which are required to boot the computer and enable function keys (e.g. airplane mode). I am not sure what they all do, but they seem to help:

nouveau.modeset=0  tpm_tis.interrupts=0 acpi_osi=! acpi_backlight=native i915.preliminary_hw_support=1

Any suggestions? All the discussions I've read involve changing the values in org.gnome.settings-daemon.plugins.power to change the behavior of the buttons.

  • Would you be happy with just having a Hibernate option in the Power Menu? There's a guide on The Ubuntu Handbook for how to get this working: ubuntuhandbook.org/index.php/2018/05/… - Might be easier than trying to get a specific key to start Hibernation – pHeLiOn Aug 7 '18 at 14:47
  • @pHeLiOn Thank you for the suggestion, but I personally really like hotkeys. I want a hotkey for everything I regularly do. I actually found a way to hotkey it by making a script that hibernates and hotkeying that, but I would still like to have the sleep hotkey do it so it is consistent with my Windows dual boot (which uses the sleep button to hibernate). – Zarquan Aug 7 '18 at 20:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.