0

I am using Ubuntu 18 on my machine and the world is beautiful. Unfortunately I need to run Windows 7 as well. So I got myself an additional SSD and installed it there just to find out that my machine will continue booting straight into Ubuntu like Windows ain't a thing. Holding F12 to select boot option manually would let me boot into windows but I'd like to have grub ask me which one I'd like to boot into. After I did some reading I realized Windows was installed in BIOS (Legacy) mode. So I looked up how to install Windows 7 in UEFI mode and the instructions were pretty straightforward:

  1. format flash drive as Fat32
  2. flag as bootable
  3. extract 100% legally obtained windows ISO on the drive
  4. reboot

Sadly at this point I can see my flash drive appear in the connected USB devices list in my BIOS but it does not recognize it as a bootable device. I'm stuck at this point as I don't know what more to look for..

3
  • You have to move some Windows boot files to /EFI/boot and rename to bootx64.efi as that is the only file UEFI uses to boot external devices. Check instructions again. I would also remove Ubuntu drive. Not sure where Windows installer will install. Not sure it gives any choice on drive and may just install to wrong drive overwriting Ubuntu as it does not correctly see ext4 partitions. – oldfred Jul 29 '18 at 21:31
  • @oldfred good pointers. So far with my previous attempt (legacy) it allowed me to partition my new ssd and clearly told me my ubuntu one is not good for it as it has no idea what ext is, so I doubt it will go trying to install stuff there (hopefully, will post back if something goes wrong) – php_nub_qq Jul 29 '18 at 21:33
  • Once installed, Windows only boots in UEFI mode from gpt partitioned drives and only in BIOS boot mode from a primary NTFS partition in BIOS mode. And if not correct partitioning it may just erase drive and convert to correct partitioning. How you boot install media UEFI or BIOS, is then how it installs for both Ubuntu & Windows. For UEFI installer must be FAT32 with boot flag as that is what UEFI reads. For Ubuntu somehow they configure a hybrid DVD/flash configuration that also works using dd to copy ISO to flash drive, but that does not work with Windows as not hybrid installer. – oldfred Jul 29 '18 at 22:41
0

Turned out my windows ISO was a piece of sh!t. Got a proper x64 ISO and everything is fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.